CVE-2019-10909: Escape validation messages in the PHP templating engine
CVE-2019-10909: Escape validation messages in the PHP templating engine
Other sources
Drupal core - Moderately critical - Multiple Vulnerabilities - SA-CORE-2019-005
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not escaped, which can lead to XSS when user input is included. This is related to symfony/framework-bundle.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/symfonyto a version that resolves this vulnerability.Fixed in 3.4.22+dfsg-2+deb10u1Fixed in 3.4.22+dfsg-2+deb10u2Fixed in 4.4.19+dfsg-2+deb11u3Fixed in 5.4.23+dfsg-1Fixed in 5.4.29+dfsg-1Fixed in 5.4.30+dfsg-1 - Upgrade
Upgrade
composer/drupal/drupalto a version that resolves this vulnerability.Fixed in 8.6.15 - Upgrade
Upgrade
composer/drupal/drupalto a version that resolves this vulnerability.Fixed in 8.5.15 - Upgrade
Upgrade
composer/drupal/coreto a version that resolves this vulnerability.Fixed in 8.5.15 - Upgrade
Upgrade
composer/drupal/coreto a version that resolves this vulnerability.Fixed in 8.6.15 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 4.2.7 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 4.1.12 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.4.26 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.8.50 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.7.51 - Upgrade
Upgrade
composer/symfony/framework-bundleto a version that resolves this vulnerability.Fixed in 4.2.7 - Upgrade
Upgrade
composer/symfony/framework-bundleto a version that resolves this vulnerability.Fixed in 4.1.12 - Upgrade
Upgrade
composer/symfony/framework-bundleto a version that resolves this vulnerability.Fixed in 3.4.26 - Upgrade
Upgrade
composer/symfony/framework-bundleto a version that resolves this vulnerability.Fixed in 2.8.50 - Upgrade
Upgrade
composer/symfony/framework-bundleto a version that resolves this vulnerability.Fixed in 2.7.51 - Upgrade
Upgrade
composer/drupal/coreto a version that resolves this vulnerability.Fixed in 7.65 - Upgrade
Upgrade
composer/drupal/coreto a version that resolves this vulnerability.Fixed in 8.5.14 - Upgrade
Upgrade
composer/drupal/coreto a version that resolves this vulnerability.Fixed in 8.6.14 - Upgrade
Upgrade
composer/drupal/drupalto a version that resolves this vulnerability.Fixed in 7.65 - Upgrade
Upgrade
composer/drupal/drupalto a version that resolves this vulnerability.Fixed in 8.5.14 - Upgrade
Upgrade
composer/drupal/drupalto a version that resolves this vulnerability.Fixed in 8.6.14
Event History
Frequently Asked Questions
What is the vulnerability ID for this vulnerability?
The vulnerability ID for this vulnerability is CVE-2019-10909.
What is the severity rating of CVE-2019-10909?
The severity rating of CVE-2019-10909 is 5.4 (medium).
What is the affected software for CVE-2019-10909?
The affected software for CVE-2019-10909 includes Symfony versions 2.7.0 to 2.7.51, 2.8.0 to 2.8.50, 3.0.0 to 3.4.26, 4.0.0 to 4.1.12, and 4.2.0 to 4.2.7.
What is the description of CVE-2019-10909?
CVE-2019-10909 is a vulnerability in Symfony where validation messages are not escaped, leading to XSS when user input is included.
Are there any reference links for CVE-2019-10909?
Yes, you can find more information about CVE-2019-10909 at the following links: [symfony.com](https://symfony.com/cve-2019-10909), [drupal.org](https://www.drupal.org/sa-core-2019-005), [nvd.nist.gov](https://nvd.nist.gov/vuln/detail/CVE-2019-10909).