CVE-2019-10911: Add a separator in the remember me cookie hash

Published Apr 16, 2019
·
Updated

CVE-2019-10911: Add a separator in the remember me cookie hash

Other sources

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled. This is related to symfony/security.

Affected Software

41 affected componentsFixes available
composer/symfony/symfony>=2.7.0, <2.7.51, >=2.8.0, <2.8.50, >=3.0.0, <3.1.0, >=3.1.0, <3.2.0, >=3.2.0, <3.3.0, >=3.3.0, <3.4.0, >=3.4.0, <3.4.26, >=4.0.0, <4.1.0, >=4.1.0, <4.1.12, >=4.2.0, <4.2.7
composer/symfony/security>=2.7.0, <2.7.51, >=2.8.0, <2.8.50, >=3.0.0, <3.1.0, >=3.1.0, <3.2.0, >=3.2.0, <3.3.0, >=3.3.0, <3.4.0, >=3.4.0, <3.4.26, >=4.0.0, <4.1.0, >=4.1.0, <4.1.12, >=4.2.0, <4.2.7
composer/symfony/security-http>=2.7.0, <2.7.51, >=2.8.0, <2.8.50, >=3.0.0, <3.1.0, >=3.1.0, <3.2.0, >=3.2.0, <3.3.0, >=3.3.0, <3.4.0, >=3.4.0, <3.4.26, >=4.0.0, <4.1.0, >=4.1.0, <4.1.12, >=4.2.0, <4.2.7
debian/symfony
3.4.22+dfsg-2+deb10u13.4.22+dfsg-2+deb10u24.4.19+dfsg-2+deb11u35.4.23+dfsg-15.4.29+dfsg-15.4.30+dfsg-1
SensioLabs Symfony>=2.7.0<2.7.51
SensioLabs Symfony>=2.8.0<2.8.50
SensioLabs Symfony>=3.4.0<3.4.26
SensioLabs Symfony>=4.1.0<4.1.12
SensioLabs Symfony>=4.2.0<4.2.7
Drupal Drupal>=8.5.0<8.5.15
Drupal Drupal>=8.6.0<8.6.15
composer/symfony/symfony>=2.7.0, <2.7.51
2.7.51
composer/symfony/symfony>=2.8.0, <2.8.50
2.8.50
composer/symfony/symfony>=3.0.0, <3.1.0
composer/symfony/symfony>=3.1.0, <3.2.0
composer/symfony/symfony>=3.2.0, <3.3.0
composer/symfony/symfony>=3.3.0, <3.4.0
composer/symfony/symfony>=3.4.0, <3.4.26
3.4.26
composer/symfony/symfony>=4.0.0, <4.1.0
composer/symfony/symfony>=4.1.0, <4.1.12
4.1.12
composer/symfony/symfony>=4.2.0, <4.2.7
4.2.7
composer/symfony/security-http>=2.7.0, <2.7.51
2.7.51
composer/symfony/security-http>=2.8.0, <2.8.50
2.8.50
composer/symfony/security-http>=3.0.0, <3.1.0
composer/symfony/security-http>=3.1.0, <3.2.0
composer/symfony/security-http>=3.2.0, <3.3.0
composer/symfony/security-http>=3.3.0, <3.4.0
composer/symfony/security-http>=3.4.0, <3.4.26
3.4.26
composer/symfony/security-http>=4.0.0, <4.1.0
composer/symfony/security-http>=4.1.0, <4.1.12
4.1.12
composer/symfony/security-http>=4.2.0, <4.2.7
4.2.7
composer/symfony/security>=2.7.0, <2.7.51
2.7.51
composer/symfony/security>=2.8.0, <2.8.50
2.8.50
composer/symfony/security>=3.0.0, <3.1.0
composer/symfony/security>=3.1.0, <3.2.0
composer/symfony/security>=3.2.0, <3.3.0
composer/symfony/security>=3.3.0, <3.4.0
composer/symfony/security>=3.4.0, <3.4.26
3.4.26
composer/symfony/security>=4.0.0, <4.1.0
composer/symfony/security>=4.1.0, <4.1.12
4.1.12
composer/symfony/security>=4.2.0, <4.2.7
4.2.7

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/symfony to a version that resolves this vulnerability.

    Fixed in 3.4.22+dfsg-2+deb10u1Fixed in 3.4.22+dfsg-2+deb10u2Fixed in 4.4.19+dfsg-2+deb11u3Fixed in 5.4.23+dfsg-1Fixed in 5.4.29+dfsg-1Fixed in 5.4.30+dfsg-1
  2. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 2.7.51
  3. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 2.8.50
  4. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 3.4.26
  5. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 4.1.12
  6. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 4.2.7
  7. Upgrade

    Upgrade composer/symfony/security-http to a version that resolves this vulnerability.

    Fixed in 2.7.51
  8. Upgrade

    Upgrade composer/symfony/security-http to a version that resolves this vulnerability.

    Fixed in 2.8.50
  9. Upgrade

    Upgrade composer/symfony/security-http to a version that resolves this vulnerability.

    Fixed in 3.4.26
  10. Upgrade

    Upgrade composer/symfony/security-http to a version that resolves this vulnerability.

    Fixed in 4.1.12
  11. Upgrade

    Upgrade composer/symfony/security-http to a version that resolves this vulnerability.

    Fixed in 4.2.7
  12. Upgrade

    Upgrade composer/symfony/security to a version that resolves this vulnerability.

    Fixed in 2.7.51
  13. Upgrade

    Upgrade composer/symfony/security to a version that resolves this vulnerability.

    Fixed in 2.8.50
  14. Upgrade

    Upgrade composer/symfony/security to a version that resolves this vulnerability.

    Fixed in 3.4.26
  15. Upgrade

    Upgrade composer/symfony/security to a version that resolves this vulnerability.

    Fixed in 4.1.12
  16. Upgrade

    Upgrade composer/symfony/security to a version that resolves this vulnerability.

    Fixed in 4.2.7
  17. Upgrade

    Upgrade symfony/security to a version that resolves this vulnerability.

    Fixed in 2.7.51
  18. Upgrade

    Upgrade symfony/security to a version that resolves this vulnerability.

    Fixed in 2.8.50
  19. Upgrade

    Upgrade symfony/security to a version that resolves this vulnerability.

    Fixed in 3.4.26
  20. Upgrade

    Upgrade symfony/security to a version that resolves this vulnerability.

    Fixed in 4.1.12
  21. Upgrade

    Upgrade symfony/security to a version that resolves this vulnerability.

    Fixed in 4.2.7

Event History

Apr 16, 2019
Advisory Published
10:54 AM
Data Sourced
via Packagist·10:54 AM
DescriptionSeverityAffected Software
May 16, 2019
CVE Published
via MITRE·09:29 PM
Data Sourced
via MITRE·09:29 PM
Description

Frequently Asked Questions

1

What is CVE-2019-10911?

CVE-2019-10911 is a vulnerability in Symfony that allows an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled.

2

Which versions of Symfony are affected by CVE-2019-10911?

Symfony versions 2.7.0 up to 2.7.51, 2.8.0 up to 2.8.50, 3.0.0 up to 3.4.26, 4.0.0 up to 4.1.12, and 4.2.0 up to 4.2.7 are affected by CVE-2019-10911.

3

How can an attacker exploit CVE-2019-10911?

An attacker can exploit CVE-2019-10911 by manipulating the remember me cookie hash to authenticate as a privileged user.

4

Is there a fix for CVE-2019-10911?

Yes, the recommended fix for CVE-2019-10911 is to upgrade Symfony to version 3.4.26, 4.1.12, or 4.2.7.

5

Where can I find more information about CVE-2019-10911?

You can find more information about CVE-2019-10911 on the Symfony website at [insert link].

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203