CVE-2019-10912: Prevent destructors with side-effects from being unserialized
CVE-2019-10912: Prevent destructors with side-effects from being unserialized
Other sources
In Symfony before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, it is possible to cache objects that may contain bad user input. On serialization or unserialization, this could result in the deletion of files that the current user has access to. This is related to symfony/cache and symfony/phpunit-bridge.
Possible deserialization side-effects in symfony/cache
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/symfonyto a version that resolves this vulnerability.Fixed in 3.4.22+dfsg-2+deb10u1Fixed in 3.4.22+dfsg-2+deb10u2Fixed in 4.4.19+dfsg-2+deb11u3Fixed in 5.4.23+dfsg-1Fixed in 5.4.29+dfsg-1Fixed in 5.4.30+dfsg-1 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 9.5.8 - Upgrade
Upgrade
composer/typo3/cms-coreto a version that resolves this vulnerability.Fixed in 9.5.8 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 4.2.7 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 4.1.12 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.4.26 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.8.50 - Upgrade
Upgrade
composer/symfony/phpunit-bridgeto a version that resolves this vulnerability.Fixed in 4.2.7 - Upgrade
Upgrade
composer/symfony/phpunit-bridgeto a version that resolves this vulnerability.Fixed in 4.1.12 - Upgrade
Upgrade
composer/symfony/phpunit-bridgeto a version that resolves this vulnerability.Fixed in 3.4.26 - Upgrade
Upgrade
composer/symfony/phpunit-bridgeto a version that resolves this vulnerability.Fixed in 2.8.50 - Upgrade
Upgrade
composer/symfony/cacheto a version that resolves this vulnerability.Fixed in 4.2.7 - Upgrade
Upgrade
composer/symfony/cacheto a version that resolves this vulnerability.Fixed in 4.1.12 - Upgrade
Upgrade
composer/symfony/cacheto a version that resolves this vulnerability.Fixed in 3.4.26
Event History
Frequently Asked Questions
What is CVE-2019-10912?
CVE-2019-10912 is a vulnerability in Symfony before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7 that allows caching of objects containing bad user input, leading to potential deletion of files.
What is the severity of CVE-2019-10912?
The severity of CVE-2019-10912 is high with a CVSS score of 7.1.
How can I fix CVE-2019-10912?
To fix CVE-2019-10912, update Symfony to version 2.8.50, 3.4.26, 4.1.12, or 4.2.7.
Where can I find more information about CVE-2019-10912?
More information about CVE-2019-10912 can be found at the TYPO3 security advisory (typo3.org/security/advisory/typo3-core-sa-2019-016) and the Symfony official website (symfony.com/cve-2019-10912 and symfony.com/blog/cve-2019-10912-prevent-destructors-with-side-effects-from-being-unserialized).
What is the CWE for CVE-2019-10912?
The CWE for CVE-2019-10912 is CWE-502: Deserialization of Untrusted Data.