CVE-2019-10913: Reject invalid HTTP method overrides
CVE-2019-10913: Reject invalid HTTP method overrides
Other sources
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/symfonyto a version that resolves this vulnerability.Fixed in 3.4.22+dfsg-2+deb10u1Fixed in 3.4.22+dfsg-2+deb10u2Fixed in 4.4.19+dfsg-2+deb11u3Fixed in 5.4.23+dfsg-1Fixed in 5.4.29+dfsg-1Fixed in 5.4.30+dfsg-1 - Upgrade
Upgrade
composer/symfony/http-foundationto a version that resolves this vulnerability.Fixed in 2.7.51 - Upgrade
Upgrade
composer/symfony/http-foundationto a version that resolves this vulnerability.Fixed in 2.8.50 - Upgrade
Upgrade
composer/symfony/http-foundationto a version that resolves this vulnerability.Fixed in 3.4.26 - Upgrade
Upgrade
composer/symfony/http-foundationto a version that resolves this vulnerability.Fixed in 4.1.12 - Upgrade
Upgrade
composer/symfony/http-foundationto a version that resolves this vulnerability.Fixed in 4.2.7 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.7.51 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.8.50 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.4.26 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 4.1.12 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 4.2.7
Event History
Frequently Asked Questions
What is CVE-2019-10913?
CVE-2019-10913 is a vulnerability in Symfony that allows malicious actors to perform SQL injection or XSS attacks.
How can CVE-2019-10913 be exploited?
CVE-2019-10913 can be exploited by sending HTTP methods provided as verbs or using the override header that are not properly validated.
What versions of Symfony are affected by CVE-2019-10913?
Versions before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7 of Symfony are affected by CVE-2019-10913.
How can I fix CVE-2019-10913?
To fix CVE-2019-10913, upgrade to version 2.7.51, 2.8.50, 3.4.26, 4.1.12, or 4.2.7 of Symfony.
Where can I find more information about CVE-2019-10913?
More information about CVE-2019-10913 can be found on the Symfony website and the Debian security tracker.