CVE-2019-12589: High severity Firejail Project Firejail vulnerability
In Firejail before 0.9.60, seccomp filters are writable inside the jail, leading to a lack of intended seccomp restrictions for a process that is joined to the jail after a filter has been modified by an attacker.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/firejailto a version that resolves this vulnerability.Fixed in 0.9.58.2-2 - Upgrade
Upgrade
debian/firejailto a version that resolves this vulnerability.Fixed in 0.9.72-2Fixed in 0.9.74-1Fixed in 0.9.80-2 - Upgrade
Upgrade
Firejailto a version that resolves this vulnerability.Fixed in 0.9.60
Event History
Frequently Asked Questions
What is CVE-2019-12589?
CVE-2019-12589 is a vulnerability in Firejail before version 0.9.60 that allows an attacker to modify seccomp filters and bypass intended restrictions.
How does CVE-2019-12589 impact Firejail?
CVE-2019-12589 impacts Firejail by allowing an attacker to modify seccomp filters, which can lead to a lack of intended restrictions for processes in the jail.
What is the severity of CVE-2019-12589?
CVE-2019-12589 has a severity rating of 8.8 (high).
Which version of Firejail is affected by CVE-2019-12589?
Firejail versions prior to 0.9.60 are affected by CVE-2019-12589.
How can I fix CVE-2019-12589?
To fix CVE-2019-12589, upgrade to Firejail version 0.9.60 or later.