CVE-2019-12854: High severity Squid-Cache Squid vulnerability
Due to incorrect string termination, Squid cachemgr.cgi 4.0 through 4.7 may access unallocated memory. On systems with memory access protections, this can cause the CGI process to terminate unexpectedly, resulting in a denial of service for all clients using it.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/squidto a version that resolves this vulnerability.Fixed in 4.13-10+deb11u3Fixed in 4.13-10+deb11u6Fixed in 5.7-2+deb12u5Fixed in 5.7-2+deb12u4Fixed in 6.13-2+deb13u1Fixed in 7.4-1
Event History
Frequently Asked Questions
What is the vulnerability ID for this vulnerability?
The vulnerability ID is CVE-2019-12854.
What is the severity level of CVE-2019-12854?
The severity level of CVE-2019-12854 is high.
What is the affected software for CVE-2019-12854?
The affected software for CVE-2019-12854 includes Squid cachemgr.cgi 4.0 through 4.7 versions.
How can CVE-2019-12854 be exploited?
CVE-2019-12854 can be exploited by accessing unallocated memory in Squid cachemgr.cgi 4.0 through 4.7 versions.
How can I fix CVE-2019-12854?
To fix CVE-2019-12854, update Squid to version 4.8-1 or apply the appropriate patches provided by the vendor.