CVE-2019-12922: phpMyAdmin Cross-Site Request Forgery (CSRF)
Published Sep 13, 2019
·Updated
A CSRF issue in phpMyAdmin 4.9.0.1 allows deletion of any server in the Setup page.
Other sources
phpMyAdmin Cross-Site Request Forgery (CSRF)
— Packagist
Affected Software
21 affected componentsFixes available
composer/phpmyadmin/phpmyadmin<=4.9.0.1
4.9.1
phpMyAdmin phpMyAdmin<=4.9.0.1
Fedoraproject Fedora=29
Fedoraproject Fedora=30
Fedoraproject Fedora=31
composer/phpmyadmin/phpmyadmin<=4.9.0.1
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
alpine/phpmyadmin<4.9.1-r0
4.9.1-r0
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.9.1 - Upgrade
Upgrade
alpine/phpmyadminto a version that resolves this vulnerability.Fixed in 4.9.1-r0
Event History
Sep 13, 2019
CVE Published
via MITRE·12:27 PM
Data Sourced
via MITRE·12:27 PM
Description
Data Sourced
via NVD·01:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:15 PM
DescriptionSeverityAffected Software
May 24, 2022
Advisory Published
via GitHub·10:00 PM
Data Sourced
via GitHub·10:00 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·10:00 PM
DescriptionSeverityAffected Software
Frequently Asked Questions
1
What is the severity of CVE-2019-12922?
The severity of CVE-2019-12922 is medium with a CVSS score of 6.5.
2
How does CVE-2019-12922 affect phpMyAdmin?
CVE-2019-12922 allows deletion of any server in the Setup page of phpMyAdmin 4.9.0.1.
3
Which versions of phpMyAdmin are affected by CVE-2019-12922?
phpMyAdmin version 4.9.0.1 is affected by CVE-2019-12922.
4
Is Fedora affected by CVE-2019-12922?
Yes, Fedora versions 29, 30, and 31 are affected by CVE-2019-12922.
5
How can I fix CVE-2019-12922 in phpMyAdmin?
Upgrade phpMyAdmin to a version higher than 4.9.0.1.