CVE-2019-13295: Buffer Overflow
ImageMagick 7.0.8-50 Q16 has a heap-based buffer over-read at MagickCore/threshold.c in AdaptiveThresholdImage because a width of zero is mishandled.
Other sources
ImageMagick is vulnerable to a heap-based buffer overflow, caused by improper bounds checking by AdaptiveThresholdImage in MagickCore/threshold.c. By sending a specially crafted command, a local attacker could overflow a buffer and execute arbitrary code on the system or cause the application to crash.
— IBM
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/ImageMagick 6.9.10to a version that resolves this vulnerability.Fixed in 50 - Upgrade
Upgrade
redhat/ImageMagick 7.0.8to a version that resolves this vulnerability.Fixed in 50 - Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u5Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1
Event History
Frequently Asked Questions
What is CVE-2019-13295?
CVE-2019-13295 is a vulnerability in ImageMagick that allows a local attacker to execute arbitrary code or cause a crash by causing a heap-based buffer overflow.
What is the severity of CVE-2019-13295?
The severity of CVE-2019-13295 is high, with a CVSS score of 8.8.
Which software is affected by CVE-2019-13295?
ImageMagick versions 7.0.8-50 Q16, ImageMagick 6.9.10, and IBM Data Risk Manager version up to 2.0.6 are affected by CVE-2019-13295.
How can I fix CVE-2019-13295?
To fix CVE-2019-13295, apply the patches provided by the respective vendors or update to the patched versions of ImageMagick or IBM Data Risk Manager.
Where can I find more information about CVE-2019-13295?
You can find more information about CVE-2019-13295 on the following references: [1], [2], [3].