CVE-2019-13917: Critical severity Exim Exim vulnerability
Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $localpart or $domain).
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/exim4to a version that resolves this vulnerability.Fixed in 4.92-8+deb10u6Fixed in 4.92-8+deb10u8Fixed in 4.94.2-7Fixed in 4.94.2-7+deb11u1Fixed in 4.96-15+deb12u1Fixed in 4.96-15+deb12u2Fixed in 4.97~RC2-2 - Upgrade
Upgrade
alpine/eximto a version that resolves this vulnerability.Fixed in 4.92.1-r0 - Upgrade
Upgrade
Eximto a version that resolves this vulnerability.Fixed in 4.92.1
Event History
Frequently Asked Questions
What is CVE-2019-13917?
CVE-2019-13917 is a vulnerability in Exim 4.85 through 4.92 that allows remote code execution as root in certain configurations.
What is the severity of CVE-2019-13917?
CVE-2019-13917 has a severity rating of critical (9.8).
How does CVE-2019-13917 allow remote code execution?
CVE-2019-13917 allows remote code execution by exploiting certain configurations that use the ${sort } expansion for controllable items, such as $local_part or $domain.
Which versions of Exim are affected by CVE-2019-13917?
Exim versions 4.85 through 4.92 are affected by CVE-2019-13917.
How can I fix CVE-2019-13917?
The vulnerability has been fixed in Exim version 4.92.1, so updating to this version or later will fix the issue.