CVE-2019-14815: High severity Linux Linux kernel vulnerability

Published Aug 21, 2019
·
Updated

A vulnerability found in the Linux kernel's WMM implementation for Marvell WiFi-based hardware (mwifiex) could lead to a denial of service or allow arbitrary code execution. For this flaw to be executed, the attacker must be both local and privileged. There is no mitigation to this flaw. A patch has been provided to remediate this flaw.

Other sources

A vulnerability was found in Linux Kernel, where a Heap Overflow was found in mwifiexsetwmmparams() function of Marvell Wifi Driver.

— Ubuntu

Affected Software

46 affected componentsFixes available
redhat/kernel-rt<0:3.10.0-1127.rt56.1093.el7
0:3.10.0-1127.rt56.1093.el7
redhat/kernel-alt<0:4.14.0-115.17.1.el7a
0:4.14.0-115.17.1.el7a
redhat/kernel<0:3.10.0-1127.el7
0:3.10.0-1127.el7
redhat/kernel-rt<0:4.18.0-147.5.1.rt24.98.el8_1
0:4.18.0-147.5.1.rt24.98.el8_1
redhat/kernel<0:4.18.0-147.5.1.el8_1
0:4.18.0-147.5.1.el8_1
Linux Linux kernel>=4.10<4.14.146
Linux Linux kernel>=4.15<4.19.75
Linux Linux kernel>=4.20<5.2.17
redhat Codeready Linux Builder Eus=8.1
redhat Codeready Linux Builder Eus=8.2
redhat Codeready Linux Builder Eus=8.4
redhat Codeready Linux Builder Eus=8.6
redhat Codeready Linux Builder For Power Little Endian Eus=8.1
redhat Codeready Linux Builder For Power Little Endian Eus=8.2
redhat Codeready Linux Builder For Power Little Endian Eus=8.4
redhat Codeready Linux Builder For Power Little Endian Eus=8.6
redhat Enterprise Linux=5
redhat Enterprise Linux=6.0
redhat Enterprise Linux=7.0
redhat Enterprise Linux=8.0
redhat Enterprise Linux For Ibm Z Systems \(structure A\)=7_s390x
redhat Enterprise Linux For Ibm Z Systems Eus=8.1
redhat Enterprise Linux For Ibm Z Systems Eus=8.2
redhat Enterprise Linux For Ibm Z Systems Eus=8.4
redhat Enterprise Linux For Ibm Z Systems Eus=8.6
redhat Enterprise Linux For Real Time=8
redhat Enterprise Linux For Real Time For Nfv=8
redhat Enterprise Linux For Real Time For Nfv Tus=8.2
redhat Enterprise Linux For Real Time For Nfv Tus=8.4
redhat Enterprise Linux For Real Time For Nfv Tus=8.6
redhat Enterprise Linux For Real Time Tus=8.2
redhat Enterprise Linux For Real Time Tus=8.4
redhat Enterprise Linux For Real Time Tus=8.6
redhat Enterprise Linux Server Aus=8.2
redhat Enterprise Linux Server Aus=8.4
redhat Enterprise Linux Server Aus=8.6
redhat Enterprise Linux Server Tus=8.2
redhat Enterprise Linux Server Tus=8.4
redhat Enterprise Linux Server Tus=8.6
NetApp AltaVault
NetApp Hci
NetApp Solidfire
NetApp Steelstore
NetApp Baseboard Management Controller
NetApp Solidfire Baseboard Management Controller Firmware
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-17.2.13-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:3.10.0-1127.rt56.1093.el7
  2. Upgrade

    Upgrade redhat/kernel-alt to a version that resolves this vulnerability.

    Fixed in 0:4.14.0-115.17.1.el7a
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:3.10.0-1127.el7
  4. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-147.5.1.rt24.98.el8_1
  5. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-147.5.1.el8_1
  6. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1

Event History

Aug 21, 2019
Data Sourced
via Red Hat·12:36 PM
DescriptionSeverityAffected Software
Aug 28, 2019
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
Nov 25, 2019
CVE Published
via MITRE·10:51 AM
Data Sourced
via MITRE·10:51 AM
DescriptionSeverityWeakness
Data Sourced
via NVD·11:15 AM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2019-14815?

CVE-2019-14815 is classified as a high-severity vulnerability due to its potential to cause denial of service or arbitrary code execution.

2

How can I patch CVE-2019-14815?

To mitigate CVE-2019-14815, apply the appropriate kernel updates provided by Red Hat for affected versions.

3

What systems are affected by CVE-2019-14815?

CVE-2019-14815 affects various Linux kernel versions, particularly those provided by Red Hat, including kernel-rt and kernel-alt packages.

4

Can CVE-2019-14815 be exploited remotely?

No, CVE-2019-14815 requires local and privileged access for exploitation.

5

Is there any workaround for CVE-2019-14815?

There is no known workaround for CVE-2019-14815; the only solution is to apply the appropriate patches.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203