CVE-2019-15604: Remotely trigger an assertion on a TLS server with a malformed certificate string

Published Feb 6, 2020
·
Updated

An encoding error flaw exists in the Node.js code that is used to read a peer certificate in the TLS client authentication. An attacker can use this flaw to crash the process used to handle TLS client authentication.

Other sources

Connecting to a NodeJS TLS server with a client certificate that has a type 19 string in its subjectAltName will crash the TLS server if it tries to read the peer certificate.

— Red Hat

Improper Certificate Validation in Node.js 10, 12, and 13 causes the process to abort when sending a crafted X.509 certificate

Remotely trigger an assertion on a TLS server with a malformed certificate string

— Node.Js

Affected Software

60 affected componentsFixes available
redhat/rh-nodejs10-nodejs<0:10.19.0-1.el7
0:10.19.0-1.el7
redhat/rh-nodejs12-nodejs<0:12.16.1-1.el7
0:12.16.1-1.el7
debian/nodejs
12.22.12~dfsg-1~deb11u412.22.12~dfsg-1~deb11u518.19.0+dfsg-6~deb12u218.19.0+dfsg-6~deb12u120.17.0+dfsg-2
Nodejs Node.js>=10.0.0<10.19.0
Nodejs Node.js>=12.0.0<12.15.0
Nodejs Node.js>=13.0.0<13.8.0
Debian Debian Linux=10.0
openSUSE Leap=15.1
redhat Software Collections=1.0
redhat Enterprise Linux=8.0
redhat Enterprise Linux Eus=8.1
redhat Enterprise Linux Eus=8.2
redhat Enterprise Linux Eus=8.4
redhat Enterprise Linux Eus=8.6
redhat Enterprise Linux Server Aus=8.2
redhat Enterprise Linux Server Aus=8.4
redhat Enterprise Linux Server Aus=8.6
redhat Enterprise Linux Server Tus=8.2
redhat Enterprise Linux Server Tus=8.4
redhat Enterprise Linux Server Tus=8.6
Oracle Communications Cloud Native Core Network Function Cloud Native Environment=1.4.0
Oracle GraalVM=19.3.1
Oracle GraalVM=20.0.0
Nodejs Node.js>=13.0.0<13.8.0
redhat/nodejs<10.19.0
10.19.0
redhat/nodejs<12.15.0
12.15.0
redhat/nodejs<13.8.0
13.8.0
Node.js Node.js>=10.0.0<10.19.0, >=12.0.0<12.15.0, >=13.0.0<13.8.0
10.19.012.15.013.8.0
Node.js Node.js>=10.0.0<10.19.0
10.19.0
Node.js Node.js>=12.0.0<12.15.0
12.15.0
Node.js Node.js>=13.0.0<13.8.0
13.8.0
alpine/nodejs<10.19.0-r0
10.19.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<12.15.0-r0
12.15.0-r0
alpine/nodejs<10.19.0-r0
10.19.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0
alpine/nodejs-current<13.11.0-r0
13.11.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/rh-nodejs10-nodejs to a version that resolves this vulnerability.

    Fixed in 0:10.19.0-1.el7
  2. Upgrade

    Upgrade redhat/rh-nodejs12-nodejs to a version that resolves this vulnerability.

    Fixed in 0:12.16.1-1.el7
  3. Upgrade

    Upgrade debian/nodejs to a version that resolves this vulnerability.

    Fixed in 12.22.12~dfsg-1~deb11u4Fixed in 12.22.12~dfsg-1~deb11u5Fixed in 18.19.0+dfsg-6~deb12u2Fixed in 18.19.0+dfsg-6~deb12u1Fixed in 20.17.0+dfsg-2
  4. Upgrade

    Upgrade redhat/nodejs to a version that resolves this vulnerability.

    Fixed in 10.19.0
  5. Upgrade

    Upgrade redhat/nodejs to a version that resolves this vulnerability.

    Fixed in 12.15.0
  6. Upgrade

    Upgrade redhat/nodejs to a version that resolves this vulnerability.

    Fixed in 13.8.0
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 10.19.0Fixed in 12.15.0Fixed in 13.8.0
  8. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 10.19.0
  9. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 12.15.0
  10. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 13.8.0
  11. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 10.19.0-r0
  12. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 12.15.0-r0
  13. Upgrade

    Upgrade alpine/nodejs-current to a version that resolves this vulnerability.

    Fixed in 13.11.0-r0

Event History

Feb 6, 2020
CVE Published
via Node.js·03:11 AM
Data Sourced
via Node.js·03:11 AM
SeverityAffected Software
Data Sourced
via Node.js·12:00 PM
Description
Feb 7, 2020
Data Sourced
via Red Hat·12:29 AM
DescriptionSeverityAffected Software
CVE Published
via MITRE·02:57 PM
Data Sourced
via MITRE·02:57 PM
DescriptionWeakness
Data Sourced
via NVD·03:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·03:15 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2019-15604?

CVE-2019-15604 is a vulnerability in Node.js that causes the process to crash when handling TLS client authentication.

2

What is the severity of CVE-2019-15604?

The severity of CVE-2019-15604 is medium with a CVSS score of 5.9.

3

How does CVE-2019-15604 affect Node.js?

CVE-2019-15604 affects Node.js versions 10, 12, and 13, causing the process to crash when handling TLS client authentication.

4

How can I fix CVE-2019-15604 in Node.js?

To fix CVE-2019-15604 in Node.js, upgrade to the patched versions: 10.24.0~dfsg-1~deb10u1 or 10.24.0~dfsg-1~deb10u3 for Debian, 12.22.12~dfsg-1~deb11u3 or 12.22.12~dfsg-1~deb11u4 for Debian, and 18.13.0+dfsg1-1 for Ubuntu.

5

Where can I find more information about CVE-2019-15604?

You can find more information about CVE-2019-15604 on the following websites: HackerOne (https://hackerone.com/reports/746733), GitHub (https://github.com/nodejs/node/commit/f940bee3b7da865e28093472dee9ce664f273f6d), and Debian Security Tracker (https://security-tracker.debian.org/tracker/CVE-2019-15604).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203