CVE-2019-16232: Null Pointer Dereference
drivers/net/wireless/marvell/libertas/ifsdio.c in the Linux kernel 5.2.14 does not check the allocworkqueue return value, leading to a NULL pointer dereference.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/linux-awsto a version that resolves this vulnerability.Fixed in 4.4.0-1090.94 - Upgrade
Upgrade
ubuntu/linux-azureto a version that resolves this vulnerability.Fixed in 4.15.0-1071.76~14.04.1 - Upgrade
Upgrade
ubuntu/linux-lts-xenialto a version that resolves this vulnerability.Fixed in 4.4.0-208.240~14.04.1 - Upgrade
Upgrade
ubuntu/linuxto a version that resolves this vulnerability.Fixed in 4.4.0-208.240 - Upgrade
Upgrade
ubuntu/linux-awsto a version that resolves this vulnerability.Fixed in 4.4.0-1126.140 - Upgrade
Upgrade
ubuntu/linux-aws-hweto a version that resolves this vulnerability.Fixed in 4.15.0-1060.62~16.04.1 - Upgrade
Upgrade
ubuntu/linux-azureto a version that resolves this vulnerability.Fixed in 4.15.0-1071.76 - Upgrade
Upgrade
ubuntu/linux-gcpto a version that resolves this vulnerability.Fixed in 4.15.0-1055.59 - Upgrade
Upgrade
ubuntu/linux-hweto a version that resolves this vulnerability.Fixed in 4.15.0-88.88~16.04.1 - Upgrade
Upgrade
ubuntu/linux-kvmto a version that resolves this vulnerability.Fixed in 4.4.0-1091.100 - Upgrade
Upgrade
ubuntu/linux-oracleto a version that resolves this vulnerability.Fixed in 4.15.0-1033.36~16.04.1 - Upgrade
Upgrade
ubuntu/linux-raspi2to a version that resolves this vulnerability.Fixed in 4.4.0-1150.161 - Upgrade
Upgrade
ubuntu/linux-snapdragonto a version that resolves this vulnerability.Fixed in 4.4.0-1154.164 - Upgrade
Upgrade
ubuntu/linux-fipsto a version that resolves this vulnerability.Fixed in 4.4.0-1060.66 - Upgrade
Upgrade
ubuntu/linuxto a version that resolves this vulnerability.Fixed in 4.15.0-88.88 - Upgrade
Upgrade
ubuntu/linux-awsto a version that resolves this vulnerability.Fixed in 4.15.0-1060.62 - Upgrade
Upgrade
ubuntu/linux-aws-5.0to a version that resolves this vulnerability.Fixed in 5.0.0-1025.28 - Upgrade
Upgrade
ubuntu/linux-azureto a version that resolves this vulnerability.Fixed in 5.0.0-1032.34 - Upgrade
Upgrade
ubuntu/linux-azure-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1013.14~18.04.1 - Upgrade
Upgrade
ubuntu/linux-gcpto a version that resolves this vulnerability.Fixed in 5.0.0-1031.32 - Upgrade
Upgrade
ubuntu/linux-gcp-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1012.13~18.04.1 - Upgrade
Upgrade
ubuntu/linux-gke-4.15to a version that resolves this vulnerability.Fixed in 4.15.0-1052.55 - Upgrade
Upgrade
ubuntu/linux-gke-5.0to a version that resolves this vulnerability.Fixed in 5.0.0-1030.31 - Upgrade
Upgrade
ubuntu/linux-gke-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1012.13~18.04.1 - Upgrade
Upgrade
ubuntu/linux-hweto a version that resolves this vulnerability.Fixed in 5.3.0-40.32~18.04.1 - Upgrade
Upgrade
ubuntu/linux-kvmto a version that resolves this vulnerability.Fixed in 4.15.0-1053.53 - Upgrade
Upgrade
ubuntu/linux-oemto a version that resolves this vulnerability.Fixed in 4.15.0-1073.83 - Upgrade
Upgrade
ubuntu/linux-oem-osp1to a version that resolves this vulnerability.Fixed in 5.0.0-1039.44 - Upgrade
Upgrade
ubuntu/linux-oracleto a version that resolves this vulnerability.Fixed in 4.15.0-1033.36 - Upgrade
Upgrade
ubuntu/linux-oracle-5.0to a version that resolves this vulnerability.Fixed in 5.0.0-1011.16 - Upgrade
Upgrade
ubuntu/linux-raspi2to a version that resolves this vulnerability.Fixed in 4.15.0-1055.59 - Upgrade
Upgrade
ubuntu/linux-raspi2-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1018.20~18.04.1 - Upgrade
Upgrade
ubuntu/linux-snapdragonto a version that resolves this vulnerability.Fixed in 4.15.0-1072.79 - Upgrade
Upgrade
ubuntu/linux-aws-fipsto a version that resolves this vulnerability.Fixed in 4.15.0-2018.18 - Upgrade
Upgrade
ubuntu/linux-azure-fipsto a version that resolves this vulnerability.Fixed in 4.15.0-2006.7
Event History
Frequently Asked Questions
What is the severity of CVE-2019-16232?
CVE-2019-16232 is classified as a vulnerability that can lead to a NULL pointer dereference, posing a security risk to affected systems.
How do I fix CVE-2019-16232?
To mitigate CVE-2019-16232, upgrade your Linux kernel to a version that includes the patch for this vulnerability, typically 5.10.x or later.
What versions of Linux are affected by CVE-2019-16232?
CVE-2019-16232 affects Linux kernel version 5.2.14 and specific Ubuntu and Fedora distributions that include this kernel version.
What kind of impact does CVE-2019-16232 have?
CVE-2019-16232 can lead to system instability or crashes due to NULL pointer dereferences in the wireless driver.
Is there a public exploit for CVE-2019-16232?
As of now, there are no widely reported public exploits targeting CVE-2019-16232.