CVE-2019-16711: Medium severity IBM Data Risk Manager vulnerability
A vulnerability was found in ImageMagick 7.0.8-40 has a memory leak in Huffman2DEncodeImage in coders/ps2.c.
Reference: https://github.com/ImageMagick/ImageMagick/issues/1542
Other sources
ImageMagick is vulnerable to a denial of service, caused by a memory leak in Huffman2DEncodeImage in coders/ps2.c. By persuading a victim to open a specially crafted file, a remote attacker could exploit this vulnerability to cause a denial of service condition.
— IBM
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/ImageMagick 7.0.8to a version that resolves this vulnerability.Fixed in 40 - Upgrade
Upgrade
redhat/ImageMagick 6.9.10to a version that resolves this vulnerability.Fixed in 40 - Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u3Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1
Event History
Frequently Asked Questions
What is CVE-2019-16711?
CVE-2019-16711 is a vulnerability in ImageMagick 7.0.8-40 that causes a memory leak in Huffman2DEncodeImage in coders/ps2.c.
How does CVE-2019-16711 impact ImageMagick?
CVE-2019-16711 can be exploited by a remote attacker to cause a denial of service condition.
What is the severity of CVE-2019-16711?
CVE-2019-16711 has a severity level of medium (6.5).
How can I fix CVE-2019-16711 in ImageMagick Data Risk Manager 2.0.6?
You can apply the patch provided by IBM to fix CVE-2019-16711 in ImageMagick Data Risk Manager 2.0.6.
How can I fix CVE-2019-16711 in Red Hat ImageMagick 7.0.8?
You can upgrade to version 7.0.9 or higher to fix CVE-2019-16711 in Red Hat ImageMagick 7.0.8.