CVE-2019-17343: Medium severity xen xapi vulnerability
An issue was discovered in Xen through 4.11.x allowing x86 PV guest OS users to cause a denial of service or gain privileges by leveraging incorrect use of the HVM physmap concept for PV domains.
Affected Software
Event History
Frequently Asked Questions
What is the severity of CVE-2019-17343?
CVE-2019-17343 has a high severity level as it allows denial of service and potential privilege escalation for x86 PV guest OS users.
How do I fix CVE-2019-17343?
To fix CVE-2019-17343, upgrade to Xen version 4.11.4+107-gef32c7afa2-1 or later, 4.14.6-1 or later, or any patched version as specified in the advisory.
What systems are affected by CVE-2019-17343?
CVE-2019-17343 affects Xen versions up to and including 4.11.2 and specific Debian releases 9.0 and 10.0.
Can CVE-2019-17343 lead to privilege escalation?
Yes, CVE-2019-17343 can allow x86 PV guest OS users to gain elevated privileges on the host system.
What type of vulnerability is CVE-2019-17343?
CVE-2019-17343 is a denial of service and privilege escalation vulnerability impacting the HVM physmap concept in Xen.