CVE-2019-17344: Medium severity xen xapi vulnerability
Published Oct 8, 2019
·Updated
An issue was discovered in Xen through 4.11.x allowing x86 PV guest OS users to cause a denial of service by leveraging a long-running operation that exists to support restartability of PTE updates.
Affected Software
4 affected componentsFixes available
debian/xen
4.11.4+107-gef32c7afa2-14.14.6-14.14.5+94-ge49571868d-14.17.2+76-ge1f9cb16e2-1~deb12u14.17.2+76-ge1f9cb16e2-1
XEN Xen<=4.11.2
Debian Debian Linux=9.0
Debian Debian Linux=10.0
Remediation
Patch Available
Event History
Oct 8, 2019
CVE Published
via MITRE·12:02 AM
Data Sourced
via MITRE·12:02 AM
Description
Frequently Asked Questions
1
What is the severity of CVE-2019-17344?
CVE-2019-17344 has a severity rating that indicates it can lead to a denial of service for x86 PV guest OS users.
2
How do I fix CVE-2019-17344?
To fix CVE-2019-17344, users should upgrade to Xen version 4.11.4+107-gef32c7afa2-1 or later.
3
Which versions of Xen are affected by CVE-2019-17344?
Xen versions up to 4.11.2 and select versions in the 4.14 and 4.17 series are affected by CVE-2019-17344.
4
Is CVE-2019-17344 specific to any Linux distribution?
Yes, CVE-2019-17344 affects Xen installations on Debian Linux versions 9.0 and 10.0.
5
What kind of attack does CVE-2019-17344 facilitate?
CVE-2019-17344 allows an attacker to perform a denial of service attack by exploiting long-running PTE updates.