CVE-2019-17345: Medium severity xen xapi vulnerability
An issue was discovered in Xen 4.8.x through 4.11.x allowing x86 PV guest OS users to cause a denial of service because mishandling of failed IOMMU operations causes a bug check during the cleanup of a crashed guest.
Affected Software
Event History
Frequently Asked Questions
What is the severity of CVE-2019-17345?
CVE-2019-17345 has been classified with a severity level that may lead to a denial of service in affected versions of Xen.
How do I fix CVE-2019-17345?
To fix CVE-2019-17345, upgrade to Xen versions 4.11.4+107-gef32c7afa2-1 or higher, or other specified secure versions.
Which versions of Xen are affected by CVE-2019-17345?
CVE-2019-17345 affects Xen versions from 4.8.x to 4.11.x, including specific Debian Linux distributions.
What type of attack does CVE-2019-17345 facilitate?
CVE-2019-17345 facilitates a denial of service attack targeting x86 PV guest operating systems.
Is CVE-2019-17345 specific to any operating system?
CVE-2019-17345 specifically impacts systems running Xen hypervisor versions within the specified range on x86 architectures.