CVE-2019-17540: Buffer Overflow
ImageMagick before 7.0.8-54 has a heap-based buffer overflow in ReadPSInfo in coders/ps.c.
Other sources
ImageMagick is vulnerable to a heap-based buffer overflow, caused by a flaw in the ReadPSInfo function in coders/ps.c. By persuading a victim to open a specially-crafted file, a remote attacker could overflow a buffer and execute arbitrary code on the system.
— IBM
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/ImageMagick 6.9.10to a version that resolves this vulnerability.Fixed in 55 - Upgrade
Upgrade
redhat/ImageMagick 7.0.8to a version that resolves this vulnerability.Fixed in 54 - Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u9Fixed in 8:6.9.11.60+dfsg-1.6+deb12u5Fixed in 8:6.9.11.60+dfsg-1.6+deb12u6Fixed in 8:7.1.1.43+dfsg1-1+deb13u4Fixed in 8:7.1.1.43+dfsg1-1+deb13u5Fixed in 8:7.1.2.13+dfsg1-1
Event History
Frequently Asked Questions
What is the severity of CVE-2019-17540?
CVE-2019-17540 is classified as a high severity vulnerability due to its potential for exploitation via a heap-based buffer overflow.
How do I fix CVE-2019-17540?
To fix CVE-2019-17540, update to ImageMagick version 7.0.8-54 or later, or apply the appropriate patches for affected versions.
Which versions of ImageMagick are affected by CVE-2019-17540?
CVE-2019-17540 affects ImageMagick versions prior to 7.0.8-54 and 6.9.10-55.
Can CVE-2019-17540 impact my application?
Yes, CVE-2019-17540 can impact applications that utilize vulnerable versions of ImageMagick for processing PostScript files.
What type of vulnerability is CVE-2019-17540?
CVE-2019-17540 is a heap-based buffer overflow vulnerability that occurs in the ReadPSInfo function in ImageMagick.