CVE-2019-19057: Low severity Linux Linux kernel vulnerability
Two memory leak flaws were found in the Linux kernel's mwifiexpcieinitevtring() function. A local attacker, able to reload the kernel module or hotplug Marvell WiFi hardware using this driver, can cause a denial of service (memory consumption) by triggering mwifiexmappcimemory() failures.
Other sources
Two memory leaks in the mwifiexpcieinitevtring() function in drivers/net/wireless/marvell/mwifiex/pcie.c in the Linux kernel through 5.3.11 allow attackers to cause a denial of service (memory consumption) by triggering mwifiexmappcimemory() failures, aka CID-d10dcb615c8e.
— Ubuntu
Two memory leaks in the mwifiexpcieinitevtring() function in drivers/net/wireless/marvell/mwifiex/pcie.c in the Linux kernel through 5.3.11 allow attackers to cause a denial of service (memory consumption) by triggering mwifiexmappcimemory() failures.
Upstream Issue:
https://github.com/torvalds/linux/commit/d10dcb615c8e29d403a24d35f8310a7a53e3050c
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:4.18.0-193.rt13.51.el8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-193.el8 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1 - Upgrade
Upgrade
ubuntu/linux-awsto a version that resolves this vulnerability.Fixed in 4.4.0-1061.65 - Upgrade
Upgrade
ubuntu/linux-azureto a version that resolves this vulnerability.Fixed in 4.15.0-1071.76~14.04.1 - Upgrade
Upgrade
ubuntu/linux-lts-xenialto a version that resolves this vulnerability.Fixed in 4.4.0-173.203~14.04.1 - Upgrade
Upgrade
ubuntu/linuxto a version that resolves this vulnerability.Fixed in 4.4.0-173.203 - Upgrade
Upgrade
ubuntu/linux-awsto a version that resolves this vulnerability.Fixed in 4.4.0-1101.112 - Upgrade
Upgrade
ubuntu/linux-aws-hweto a version that resolves this vulnerability.Fixed in 4.15.0-1060.62~16.04.1 - Upgrade
Upgrade
ubuntu/linux-azureto a version that resolves this vulnerability.Fixed in 4.15.0-1071.76 - Upgrade
Upgrade
ubuntu/linux-gcpto a version that resolves this vulnerability.Fixed in 4.15.0-1055.59 - Upgrade
Upgrade
ubuntu/linux-hweto a version that resolves this vulnerability.Fixed in 4.15.0-88.88~16.04.1 - Upgrade
Upgrade
ubuntu/linux-kvmto a version that resolves this vulnerability.Fixed in 4.4.0-1065.72 - Upgrade
Upgrade
ubuntu/linux-oracleto a version that resolves this vulnerability.Fixed in 4.15.0-1033.36~16.04.1 - Upgrade
Upgrade
ubuntu/linux-raspi2to a version that resolves this vulnerability.Fixed in 4.4.0-1128.137 - Upgrade
Upgrade
ubuntu/linux-snapdragonto a version that resolves this vulnerability.Fixed in 4.4.0-1132.140 - Upgrade
Upgrade
ubuntu/linux-fipsto a version that resolves this vulnerability.Fixed in 4.4.0-1028.33 - Upgrade
Upgrade
ubuntu/linuxto a version that resolves this vulnerability.Fixed in 4.15.0-88.88 - Upgrade
Upgrade
ubuntu/linux-awsto a version that resolves this vulnerability.Fixed in 4.15.0-1060.62 - Upgrade
Upgrade
ubuntu/linux-aws-5.0to a version that resolves this vulnerability.Fixed in 5.0.0-1025.28 - Upgrade
Upgrade
ubuntu/linux-azureto a version that resolves this vulnerability.Fixed in 5.0.0-1032.34 - Upgrade
Upgrade
ubuntu/linux-azure-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1013.14~18.04.1 - Upgrade
Upgrade
ubuntu/linux-gcpto a version that resolves this vulnerability.Fixed in 5.0.0-1031.32 - Upgrade
Upgrade
ubuntu/linux-gcp-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1012.13~18.04.1 - Upgrade
Upgrade
ubuntu/linux-gke-4.15to a version that resolves this vulnerability.Fixed in 4.15.0-1052.55 - Upgrade
Upgrade
ubuntu/linux-gke-5.0to a version that resolves this vulnerability.Fixed in 5.0.0-1030.31 - Upgrade
Upgrade
ubuntu/linux-gke-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1012.13~18.04.1 - Upgrade
Upgrade
ubuntu/linux-hweto a version that resolves this vulnerability.Fixed in 5.3.0-40.32~18.04.1 - Upgrade
Upgrade
ubuntu/linux-kvmto a version that resolves this vulnerability.Fixed in 4.15.0-1053.53 - Upgrade
Upgrade
ubuntu/linux-oemto a version that resolves this vulnerability.Fixed in 4.15.0-1073.83 - Upgrade
Upgrade
ubuntu/linux-oem-osp1to a version that resolves this vulnerability.Fixed in 5.0.0-1039.44 - Upgrade
Upgrade
ubuntu/linux-oracleto a version that resolves this vulnerability.Fixed in 4.15.0-1033.36 - Upgrade
Upgrade
ubuntu/linux-oracle-5.0to a version that resolves this vulnerability.Fixed in 5.0.0-1011.16 - Upgrade
Upgrade
ubuntu/linux-raspi2to a version that resolves this vulnerability.Fixed in 4.15.0-1055.59 - Upgrade
Upgrade
ubuntu/linux-raspi2-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1018.20~18.04.1 - Upgrade
Upgrade
ubuntu/linux-snapdragonto a version that resolves this vulnerability.Fixed in 4.15.0-1072.79 - Upgrade
Upgrade
ubuntu/linux-aws-fipsto a version that resolves this vulnerability.Fixed in 4.15.0-2018.18 - Upgrade
Upgrade
ubuntu/linux-azure-fipsto a version that resolves this vulnerability.Fixed in 4.15.0-2006.7
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2019-19057?
CVE-2019-19057 is classified as a medium-severity vulnerability due to its potential to cause denial of service through memory consumption.
How do I fix CVE-2019-19057?
To fix CVE-2019-19057, update your Linux kernel to version 0:4.18.0-193.rt13.51.el8, 0:4.18.0-193.el8, or apply any other available patches from your distribution.
Who is affected by CVE-2019-19057?
CVE-2019-19057 affects systems running certain versions of the Linux kernel, specifically those that utilize the mwifiex_pcie driver.
What type of vulnerability is CVE-2019-19057?
CVE-2019-19057 is a memory leak vulnerability that can be exploited by local attackers to deplete system memory resources.
What systems should be prioritized for the CVE-2019-19057 update?
Systems running affected versions of the Linux kernel, particularly those using Marvell WiFi hardware, should be prioritized for updates.