CVE-2019-19319: Use After Free

Published Nov 27, 2019
·
Updated

An out-of-bounds write flaw was found in the Linux kernel’s Ext4 FileSystem in the way it uses a crafted ext4 image. This flaw allows a local user with physical access to crash the system or potentially escalate their privileges on the system.

Other sources

In the Linux kernel 5.0.21, a setxattr operation, after a mount of a crafted ext4 image, can cause a slab-out-of-bounds write access because of an ext4xattrsetentry use-after-free in fs/ext4/xattr.c when a large oldsize value is used in a memset call.

Reference: https://github.com/bobfuzzer/CVE/tree/master/CVE-2019-19319

— Red Hat

In the Linux kernel before 5.2, a setxattr operation, after a mount of a crafted ext4 image, can cause a slab-out-of-bounds write access because of an ext4xattrsetentry use-after-free in fs/ext4/xattr.c when a large oldsize value is used in a memset call, aka CID-345c0dbf3a30.

— Ubuntu

Affected Software

7 affected componentsFixes available
redhat/kernel-rt<0:4.18.0-240.rt7.54.el8
0:4.18.0-240.rt7.54.el8
redhat/kernel<0:4.18.0-240.el8
0:4.18.0-240.el8
Linux Linux kernel=5.0.21
openSUSE Leap=15.1
redhat Enterprise Linux=7.0
redhat Enterprise Linux=8.0
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-240.rt7.54.el8
  2. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-240.el8
  3. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Nov 27, 2019
CVE Published
12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·10:48 PM
Data Sourced
via MITRE·10:48 PM
Description
Data Sourced
via NVD·11:15 PM
DescriptionSeverityWeaknessAffected Software
Dec 16, 2019
Data Sourced
via Red Hat·06:50 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2019-19319?

CVE-2019-19319 is classified as a high severity vulnerability due to the potential for privilege escalation and system crashes.

2

How do I fix CVE-2019-19319?

To fix CVE-2019-19319, upgrade to kernel version 0:4.18.0-240.rt7.54.el8 or 0:4.18.0-240.el8 for Red Hat, or to the recommended versions for Debian including 5.10.223-1.

3

What systems are affected by CVE-2019-19319?

CVE-2019-19319 affects specific versions of the Linux kernel, including 5.0.21 and earlier, as well as Red Hat and openSUSE distributions.

4

Is there a workaround for CVE-2019-19319?

There are no known workarounds for CVE-2019-19319, so updating to a patched version is recommended.

5

Who is vulnerable to CVE-2019-19319?

Local users with physical access to the system may exploit CVE-2019-19319 to crash the system or escalate privileges.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203