CVE-2019-19481: Buffer Overflow
An issue was discovered in OpenSC through 0.19.0 and 0.20.x through 0.20.0-rc3. libopensc/card-cac1.c mishandles buffer limits for CAC certificates.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/openscto a version that resolves this vulnerability.Fixed in 0.20.0-r0
Event History
Frequently Asked Questions
What is CVE-2019-19481?
CVE-2019-19481 is a vulnerability discovered in OpenSC through versions 0.19.0 and 0.20.x through 0.20.0-rc3. It mishandles buffer limits for CAC certificates in the libopensc/card-cac1.c file.
How severe is CVE-2019-19481?
CVE-2019-19481 has a severity level of 4.6, which is considered medium severity.
Which software versions are affected by CVE-2019-19481?
Versions 0.19.0, 0.20.0-rc1, 0.20.0-rc2, and 0.20.0-rc3 of OpenSC are affected by CVE-2019-19481.
How can I fix CVE-2019-19481?
To fix CVE-2019-19481, users should update to the latest version of OpenSC available.
Where can I find more information about CVE-2019-19481?
More information about CVE-2019-19481 can be found at the following references: [1] [2] [3].