CVE-2019-19947: Medium severity Linux Linux kernel vulnerability
In the Linux kernel through 5.4.6, there are information leaks of uninitialized memory to a USB device in the drivers/net/can/usb/kvaserusb/kvaserusbleaf.c driver, aka CID-da2311a6385c.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.11-1Fixed in 7.2.12-1 - Upgrade
Upgrade
ubuntu/linux-awsto a version that resolves this vulnerability.Fixed in 4.4.0-1075.79 - Upgrade
Upgrade
ubuntu/linux-azureto a version that resolves this vulnerability.Fixed in 4.15.0-1093.103~14.04.1 - Upgrade
Upgrade
ubuntu/linux-lts-xenialto a version that resolves this vulnerability.Fixed in 4.4.0-186.216~14.04.1 - Upgrade
Upgrade
ubuntu/linuxto a version that resolves this vulnerability.Fixed in 4.4.0-186.216 - Upgrade
Upgrade
ubuntu/linux-awsto a version that resolves this vulnerability.Fixed in 4.4.0-1111.123 - Upgrade
Upgrade
ubuntu/linux-aws-hweto a version that resolves this vulnerability.Fixed in 4.15.0-1080.84~16.04.1 - Upgrade
Upgrade
ubuntu/linux-azureto a version that resolves this vulnerability.Fixed in 4.15.0-1093.103~16.04.1 - Upgrade
Upgrade
ubuntu/linux-gcpto a version that resolves this vulnerability.Fixed in 4.15.0-1081.92~16.04.1 - Upgrade
Upgrade
ubuntu/linux-hweto a version that resolves this vulnerability.Fixed in 4.15.0-115.116~16.04.1 - Upgrade
Upgrade
ubuntu/linux-kvmto a version that resolves this vulnerability.Fixed in 4.4.0-1077.84 - Upgrade
Upgrade
ubuntu/linux-oracleto a version that resolves this vulnerability.Fixed in 4.15.0-1051.55~16.04.1 - Upgrade
Upgrade
ubuntu/linux-raspi2to a version that resolves this vulnerability.Fixed in 4.4.0-1136.145 - Upgrade
Upgrade
ubuntu/linux-snapdragonto a version that resolves this vulnerability.Fixed in 4.4.0-1140.148 - Upgrade
Upgrade
ubuntu/linux-fipsto a version that resolves this vulnerability.Fixed in 4.4.0-1043.48 - Upgrade
Upgrade
ubuntu/linuxto a version that resolves this vulnerability.Fixed in 4.15.0-115.116 - Upgrade
Upgrade
ubuntu/linux-awsto a version that resolves this vulnerability.Fixed in 4.15.0-1080.84 - Upgrade
Upgrade
ubuntu/linux-aws-5.0to a version that resolves this vulnerability.Fixed in 5.0.0-1025.28 - Upgrade
Upgrade
ubuntu/linux-azureto a version that resolves this vulnerability.Fixed in 5.0.0-1032.34 - Upgrade
Upgrade
ubuntu/linux-azure-4.15to a version that resolves this vulnerability.Fixed in 4.15.0-1093.103 - Upgrade
Upgrade
ubuntu/linux-azure-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1013.14~18.04.1 - Upgrade
Upgrade
ubuntu/linux-gcpto a version that resolves this vulnerability.Fixed in 5.0.0-1031.32 - Upgrade
Upgrade
ubuntu/linux-gcp-4.15to a version that resolves this vulnerability.Fixed in 4.15.0-1081.92 - Upgrade
Upgrade
ubuntu/linux-gcp-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1012.13~18.04.1 - Upgrade
Upgrade
ubuntu/linux-gke-4.15to a version that resolves this vulnerability.Fixed in 4.15.0-1067.70 - Upgrade
Upgrade
ubuntu/linux-gke-5.0to a version that resolves this vulnerability.Fixed in 5.0.0-1030.31 - Upgrade
Upgrade
ubuntu/linux-gke-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1012.13~18.04.1 - Upgrade
Upgrade
ubuntu/linux-hweto a version that resolves this vulnerability.Fixed in 5.3.0-40.32~18.04.1 - Upgrade
Upgrade
ubuntu/linux-kvmto a version that resolves this vulnerability.Fixed in 4.15.0-1072.73 - Upgrade
Upgrade
ubuntu/linux-oemto a version that resolves this vulnerability.Fixed in 4.15.0-1094.104 - Upgrade
Upgrade
ubuntu/linux-oem-osp1to a version that resolves this vulnerability.Fixed in 5.0.0-1039.44 - Upgrade
Upgrade
ubuntu/linux-oracleto a version that resolves this vulnerability.Fixed in 4.15.0-1051.55 - Upgrade
Upgrade
ubuntu/linux-oracle-5.0to a version that resolves this vulnerability.Fixed in 5.0.0-1011.16 - Upgrade
Upgrade
ubuntu/linux-raspi2to a version that resolves this vulnerability.Fixed in 4.15.0-1068.72 - Upgrade
Upgrade
ubuntu/linux-raspi2-5.3to a version that resolves this vulnerability.Fixed in 5.3.0-1018.20~18.04.1 - Upgrade
Upgrade
ubuntu/linux-snapdragonto a version that resolves this vulnerability.Fixed in 4.15.0-1084.92 - Upgrade
Upgrade
ubuntu/linux-aws-fipsto a version that resolves this vulnerability.Fixed in 4.15.0-2025.25 - Upgrade
Upgrade
ubuntu/linux-azure-fipsto a version that resolves this vulnerability.Fixed in 4.15.0-2007.8 - Upgrade
Upgrade
ubuntu/linux-fipsto a version that resolves this vulnerability.Fixed in 4.15.0-1039.44
Event History
Frequently Asked Questions
What is the severity of CVE-2019-19947?
CVE-2019-19947 is classified as a moderate severity vulnerability due to potential information leaks of uninitialized memory.
How do I fix CVE-2019-19947?
To fix CVE-2019-19947, upgrade to Linux kernel version 5.10.223-1 or later as specified in the remediation guidelines.
Which Linux versions are affected by CVE-2019-19947?
CVE-2019-19947 affects Linux kernel versions up to 5.4.6, including specific Debian and Ubuntu distributions.
What type of vulnerability is CVE-2019-19947?
CVE-2019-19947 is an information disclosure vulnerability occurring within the kvaser_usb_leaf.c driver.
Is CVE-2019-19947 a zero-day vulnerability?
CVE-2019-19947 was publicly disclosed before the patch was released, but it is no longer considered a zero-day as fixes are available.