CVE-2019-20479: Medium severity openidc Mod Auth Openidc vulnerability
A flaw was found in modauthopenidc before version 2.4.1. An open redirect issue exists in URLs with a slash and backslash at the beginning.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
mod_auth_openidcto a version that resolves this vulnerability.Fixed in 2.4.1
Event History
Frequently Asked Questions
What is CVE-2019-20479?
CVE-2019-20479 is a vulnerability found in mod_auth_openidc before version 2.4.1.
What is the severity of CVE-2019-20479?
The severity of CVE-2019-20479 is medium, with a severity value of 6.1.
What is the affected software for CVE-2019-20479?
The affected software includes Openidc Mod Auth Openidc before version 2.4.1, Debian Linux 8.0 and 9.0, Fedora 31 and 32, and openSUSE Leap 15.1.
What is the vulnerability in CVE-2019-20479?
The vulnerability in CVE-2019-20479 is an open redirect issue in URLs with a slash and backslash at the beginning.
How do I fix CVE-2019-20479?
To fix CVE-2019-20479, users should update to mod_auth_openidc version 2.4.1 or later.