CVE-2019-20811: Medium severity Linux Linux kernel vulnerability
A flaw was found in the way the rxqueueaddkobject and netdevqueueaddkobject functions in the Linux kernel handled refcounting of certain objects. This flaw allows a local user who can trigger the error code path to use this vulnerability to disturb the integrity of the system.
Other sources
An issue was discovered in the Linux kernel before 5.0.6. In rxqueueaddkobject() and netdevqueueaddkobject() in net/core/net-sysfs.c, a reference count is mishandled, aka CID-a3e23f719f5c.
— Ubuntu
An issue was discovered in the Linux kernel. In rxqueueaddkobject() and netdevqueueaddkobject() in net/core/net-sysfs.c, a reference count is mishandled.
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:3.10.0-1160.6.1.rt56.1139.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-1160.6.1.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-147.el8 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 5.0.6
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2019-20811?
CVE-2019-20811 has been classified as a medium-level severity vulnerability.
How do I fix CVE-2019-20811?
To fix CVE-2019-20811, update your kernel package to the specified remedial versions provided by your Linux distribution.
What systems are affected by CVE-2019-20811?
CVE-2019-20811 affects various Linux kernel versions including specific Red Hat, Debian, and Ubuntu distributions.
Can CVE-2019-20811 be exploited remotely?
CVE-2019-20811 is primarily a local vulnerability that requires a local user to exploit it.
Is CVE-2019-20811 a denial-of-service vulnerability?
CVE-2019-20811 can potentially disturb the integrity of the system but is not specifically categorized as a denial-of-service vulnerability.