CVE-2019-5785: Stack buffer overflow in Skia

Published Oct 29, 2018
·
Updated

An integer overflow vulnerability in the Skia library can occur after specific transform operations, leading to a potentially exploitable crash.

Other sources

Incorrect convexity calculations in Skia in Google Chrome prior to 72.0.3626.81 allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.

— Launchpad

Credit

Ivan Fratric(Google Project Zero)

Affected Software

26 affected componentsFixes available
redhat/firefox esr<60.5.1
60.5.1
redhat/firefox<65.0.1
65.0.1
redhat/thunderbird<60.5.1
60.5.1
Mozilla Firefox<65.0.1
65.0.1
Mozilla Firefox ESR<60.5.1
60.5.1
Google Chrome<72.0.3626.81
72.0.3626.81
Google Chrome<72.0.3626.81
Mozilla Thunderbird<60.5.1
60.5.1
debian/firefox
159.0-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0
alpine/firefox-esr<60.5.2-r0
60.5.2-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/firefox ESR to a version that resolves this vulnerability.

    Fixed in 60.5.1
  2. Upgrade

    Upgrade redhat/firefox to a version that resolves this vulnerability.

    Fixed in 65.0.1
  3. Upgrade

    Upgrade redhat/thunderbird to a version that resolves this vulnerability.

    Fixed in 60.5.1
  4. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 65.0.1
  5. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 60.5.1
  6. Upgrade

    Upgrade Google Chrome (Trace Event) to a version that resolves this vulnerability.

    Fixed in 72.0.3626.81
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 60.5.1
  8. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0-1
  9. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  10. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u1Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.5.1esr-1~deb13u2Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  11. Upgrade

    Upgrade Google Chrome to a version that resolves this vulnerability.

    Fixed in 72.0.3626.81

Event History

Oct 29, 2018
CVE Published
12:00 AM
Feb 14, 2019
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
Jun 27, 2019
CVE Published
via MITRE·04:13 PM
Data Sourced
via MITRE·04:13 PM
DescriptionWeakness
Data Sourced
via NVD·05:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·05:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2019-5785?

CVE-2019-5785 is an integer overflow vulnerability in the Skia library that can occur after specific transform operations in Google Chrome prior to 72.0.3626.81.

2

How severe is CVE-2019-5785?

CVE-2019-5785 has a severity rating of 6.5, which is considered high.

3

What software is affected by CVE-2019-5785?

CVE-2019-5785 affects Google Chrome prior to 72.0.3626.81, Mozilla Firefox versions up to 65.0.1, and Mozilla Firefox ESR versions up to 60.5.1.

4

How can I fix CVE-2019-5785?

To fix CVE-2019-5785, update your software to Google Chrome version 72.0.3626.81 or later, Mozilla Firefox version 65.0.1 or later, or Mozilla Firefox ESR version 60.5.1 or later.

5

Where can I find more information about CVE-2019-5785?

You can find more information about CVE-2019-5785 on the following websites: [Bugzilla](https://bugzilla.mozilla.org/show_bug.cgi?id=1525433), [Google Project Zero Blog](https://googleprojectzero.blogspot.com/2019/02/the-curious-case-of-convexity-confusion.html), [Mozilla Security Advisories](https://www.mozilla.org/en-US/security/advisories/mfsa2019-05/).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203