CVE-2019-5815: Heap buffer overflow in Blink

Published Feb 11, 2019
·
Updated

Type confusion in xsltNumberFormatGetMultipleLevel prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via crafted XML data.

Credit

Nicolas Grégoire, Agarri

Affected Software

5 affected componentsFixes available
Google Chrome<74.0.3729.108
74.0.3729.108
Xmlsoft Libxslt<1.1.33
Debian Debian Linux=10.0
debian/chromium
150.0.7871.100-1~deb12u1156.0.8078.73-1~deb12u1150.0.7871.181-1~deb13u1156.0.8078.73-1~deb13u1156.0.8078.47-1156.0.8078.79-1
debian/libxslt
1.1.35-1+deb12u41.1.35-1+deb12u31.1.35-1.2+deb13u31.1.35-1.2+deb13u21.1.45-0.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Google Chrome (Trace Event) to a version that resolves this vulnerability.

    Fixed in 74.0.3729.108
  2. Upgrade

    Upgrade debian/chromium to a version that resolves this vulnerability.

    Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1
  3. Upgrade

    Upgrade debian/libxslt to a version that resolves this vulnerability.

    Fixed in 1.1.35-1+deb12u4Fixed in 1.1.35-1+deb12u3Fixed in 1.1.35-1.2+deb13u3Fixed in 1.1.35-1.2+deb13u2Fixed in 1.1.45-0.1

Event History

Feb 11, 2019
CVE Published
12:00 AM
Dec 11, 2019
CVE Published
via MITRE·12:55 AM
Data Sourced
via MITRE·12:55 AM
Description
Data Sourced
via OSV·01:15 AM
DescriptionSeverity

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2019-5815?

CVE-2019-5815 is a vulnerability that allows attackers to potentially exploit heap corruption via crafted XML data.

2

What is the severity of CVE-2019-5815?

CVE-2019-5815 has a severity level of 7.5 (high).

3

How does CVE-2019-5815 affect the affected software?

CVE-2019-5815 affects the software mentioned in the 'affected_software' field, specifically 'libxslt' and 'chromium' on certain debian/linux versions.

4

How can CVE-2019-5815 be fixed?

To fix CVE-2019-5815, users should update to the recommended versions mentioned in the 'affected_software' field or apply the provided patches from the official sources.

5

Where can I find more information about CVE-2019-5815?

More information about CVE-2019-5815 can be found in the references provided: [link1], [link2], [link3].

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203