CVE-2019-6474: A packet containing a malformed DUID can cause the kea-dhcp6 server to terminate

Published Oct 16, 2019
·
Updated

A missing check on incoming client requests can be exploited to cause a situation where the Kea server's lease storage contains leases which are rejected as invalid when the server tries to load leases from storage on restart. If the number of such leases exceeds a hard-coded limit in the Kea code, a server trying to restart will conclude that there is a problem with its lease store and give up. Versions affected: 1.4.0 to 1.5.0, 1.6.0-beta1, and 1.6.0-beta2

Affected Software

17 affected componentsFixes available
ISC kea>=1.4.0<=1.5.0
ISC kea=1.6.0-beta1
ISC kea=1.6.0-beta2
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0
alpine/kea>=1.4.0<1.7.2-r0
1.7.2-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/kea to a version that resolves this vulnerability.

    Fixed in 1.7.2-r0
  2. Upgrade

    Upgrade Kea to a version that resolves this vulnerability.

    Fixed in 1.4.0-P2
  3. Upgrade

    Upgrade Kea to a version that resolves this vulnerability.

    Fixed in 1.5.0-P1
  4. Upgrade

    Upgrade Kea to a version that resolves this vulnerability.

    Fixed in 1.6.0

Event History

Oct 16, 2019
CVE Published
via MITRE·05:22 PM
Data Sourced
via MITRE·05:22 PM
RemedyDescriptionSeverityWeakness
Data Sourced
via NVD·06:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·06:15 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2019-6474?

CVE-2019-6474 is a vulnerability in the Kea server where a missing check on incoming client requests can be exploited to cause invalid leases in the server's lease storage.

2

How severe is CVE-2019-6474?

CVE-2019-6474 has a severity score of 6.5, which is considered medium.

3

Which software versions are affected by CVE-2019-6474?

The affected software versions are ISC Kea 1.4.0 to 1.5.0, ISC Kea 1.6.0-beta1, and ISC Kea 1.6.0-beta2.

4

How can CVE-2019-6474 be fixed?

To fix CVE-2019-6474, users should apply the latest security patches provided by ISC Kea.

5

Is there any additional information available for CVE-2019-6474?

Yes, you can find more information about CVE-2019-6474 in the ISC Knowledge Base at https://kb.isc.org/docs/cve-2019-6474.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203