CVE-2019-6798: phpMyAdmin SQL injection in Designer feature
An issue was discovered in phpMyAdmin before 4.8.5. A vulnerability was reported where a specially crafted username can be used to trigger a SQL injection attack through the designer feature.
Other sources
phpMyAdmin SQL injection in Designer feature
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.8.5 - Upgrade
Upgrade
alpine/phpmyadminto a version that resolves this vulnerability.Fixed in 4.8.5-r0
Event History
Frequently Asked Questions
What is CVE-2019-6798?
CVE-2019-6798 is a vulnerability in phpMyAdmin before version 4.8.5 that allows a specially crafted username to trigger a SQL injection attack through the designer feature.
What is the severity of CVE-2019-6798?
CVE-2019-6798 has a severity rating of 9.8 out of 10, which is classified as critical.
How does CVE-2019-6798 affect phpMyAdmin?
CVE-2019-6798 affects phpMyAdmin versions between 4.5.0 and 4.8.4, allowing a SQL injection attack using a specially crafted username in the designer feature.
Is there a fix for CVE-2019-6798?
Yes, the vulnerability has been fixed in phpMyAdmin version 4.8.5 or later. It is recommended to upgrade to the latest version.
Where can I find more information about CVE-2019-6798?
You can find more information about CVE-2019-6798 on the following references: http://www.securityfocus.com/bid/106727, https://www.phpmyadmin.net/security/PMASA-2019-2/