CVE-2019-6799: phpMyAdmin Arbitrary file read vulnerability

Published Jan 26, 2019
·
Updated

An issue was discovered in phpMyAdmin before 4.8.5. When the AllowArbitraryServer configuration setting is set to true, with the use of a rogue MySQL server, an attacker can read any file on the server that the web server's user can access. This is related to the mysql.allowlocalinfile PHP configuration, and the inadvertent ignoring of "options(MYSQLIOPTLOCALINFILE" calls.

Other sources

phpMyAdmin Arbitrary file read vulnerability

— Packagist

Affected Software

20 affected componentsFixes available
composer/phpmyadmin/phpmyadmin>=4.8<4.8.5
4.8.5
phpMyAdmin phpMyAdmin>=4.0.0<=4.8.4
Debian Debian Linux=8.0
composer/phpmyadmin/phpmyadmin>=4.8, <4.8.5
4.8.5
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0
alpine/phpmyadmin>=4.0.0<4.8.5-r0
4.8.5-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/phpmyadmin/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.8.5
  2. Upgrade

    Upgrade alpine/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.8.5-r0
  3. Upgrade

    Upgrade phpMyAdmin to a version that resolves this vulnerability.

    Fixed in 4.8.5

Event History

Jan 26, 2019
CVE Published
via MITRE·05:00 PM
Data Sourced
via MITRE·05:00 PM
Description
Data Sourced
via NVD·05:29 PM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·05:29 PM
DescriptionSeverityAffected Software
May 13, 2022
Advisory Published
via GitHub·01:22 AM
Data Sourced
via GitHub·01:22 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·01:22 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2019-6799?

The severity of CVE-2019-6799 is medium.

2

How does CVE-2019-6799 affect phpMyAdmin?

CVE-2019-6799 allows an attacker to read any file on the server that the web server's user can access.

3

What is the affected software for CVE-2019-6799?

The affected software for CVE-2019-6799 is phpMyAdmin versions before 4.8.5 and Debian Linux 8.0.

4

How can I fix CVE-2019-6799?

To fix CVE-2019-6799, update phpMyAdmin to version 4.8.5 or above and apply the necessary security patches for Debian Linux.

5

Where can I find more information about CVE-2019-6799?

You can find more information about CVE-2019-6799 at the following references: http://www.securityfocus.com/bid/106736, https://lists.debian.org/debian-lts-announce/2019/02/msg00039.html, https://www.phpmyadmin.net/security/PMASA-2019-1/

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203