CVE-2020-0238: Race Condition

Published Aug 1, 2020
·
Updated

In updatePreferenceIntents of AccountTypePreferenceLoader, there is a possible confused deputy attack due to a race condition. This could lead to local escalation of privilege and launching privileged activities with no additional execution privileges needed. User interaction is not needed for exploitation.

Affected Software

9 affected componentsFixes available
Google Android=8.0
Google Android=8.1
Google Android=9.0
Google Android=10.0
Google Android
android/platform/packages/apps/settings>=8.0:0<8.0:2020-08-01
8.0:2020-08-01
android/platform/packages/apps/settings>=8.1:0<8.1:2020-08-01
8.1:2020-08-01
android/platform/packages/apps/settings>=9:0<9:2020-08-01
9:2020-08-01
android/platform/packages/apps/settings>=10:0<10:2020-08-01
10:2020-08-01

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade android/platform/packages/apps/Settings to a version that resolves this vulnerability.

    Fixed in 8.0:2020-08-01
  2. Upgrade

    Upgrade android/platform/packages/apps/Settings to a version that resolves this vulnerability.

    Fixed in 8.1:2020-08-01
  3. Upgrade

    Upgrade android/platform/packages/apps/Settings to a version that resolves this vulnerability.

    Fixed in 9:2020-08-01
  4. Upgrade

    Upgrade android/platform/packages/apps/Settings to a version that resolves this vulnerability.

    Fixed in 10:2020-08-01

Event History

Aug 1, 2020
Advisory Published
via OSV·12:00 AM
Data Sourced
via OSV·12:00 AM
DescriptionAffected Software
Aug 3, 2020
CVE Published
via Android·12:00 AM
Data Sourced
via Android·12:00 AM
SeverityWeaknessAffected Software
Aug 11, 2020
CVE Published
via MITRE·07:26 PM
Data Sourced
via MITRE·07:26 PM
DescriptionWeakness

Frequently Asked Questions

1

What is the severity of CVE-2020-0238?

CVE-2020-0238 is categorized as a critical vulnerability due to its potential for local escalation of privilege.

2

How do I fix CVE-2020-0238?

To fix CVE-2020-0238, ensure that your device is updated to the latest version of Android that addresses this vulnerability.

3

Which versions of Android are affected by CVE-2020-0238?

CVE-2020-0238 affects Android versions 8.0, 8.1, 9.0, and 10.0.

4

What kind of attack is associated with CVE-2020-0238?

CVE-2020-0238 is associated with a confused deputy attack due to a race condition.

5

Is user interaction required to exploit CVE-2020-0238?

No, user interaction is not required to exploit CVE-2020-0238, making it more dangerous.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203