CVE-2020-10018: Use After Free

Published Mar 2, 2020
·
Updated

accessibility/AXObjectCache.cpp in WebKit, as used in WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4, allows a denial of service (application crash) because maintenance of the mdeferredFocusedNodeChange data structure mishandles removal.

Upstream patch:

https://trac.webkit.org/changeset/257292/webkit

Other sources

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.

— Launchpad

Affected Software

21 affected componentsFixes available
redhat/webkitgtk<2.28.0
2.28.0
WebKitGTK WebKitGTK<2.28.0
wpewebkit WPE WebKit<2.28.0
Fedoraproject Fedora=30
Fedoraproject Fedora=31
Debian Debian Linux=10.0
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=19.10
openSUSE Leap=15.1
debian/webkit2gtk
2.44.2-1~deb11u12.50.4-1~deb11u12.50.4-1~deb12u12.50.4-1~deb13u12.50.5-1
debian/wpewebkit
2.38.6-1~deb11u12.38.6-12.48.3-12.50.5-1
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0
alpine/webkit2gtk<2.28.0-r0
2.28.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/webkitgtk to a version that resolves this vulnerability.

    Fixed in 2.28.0
  2. Upgrade

    Upgrade debian/webkit2gtk to a version that resolves this vulnerability.

    Fixed in 2.44.2-1~deb11u1Fixed in 2.50.4-1~deb11u1Fixed in 2.50.4-1~deb12u1Fixed in 2.50.4-1~deb13u1Fixed in 2.50.5-1
  3. Upgrade

    Upgrade debian/wpewebkit to a version that resolves this vulnerability.

    Fixed in 2.38.6-1~deb11u1Fixed in 2.38.6-1Fixed in 2.48.3-1Fixed in 2.50.5-1
  4. Upgrade

    Upgrade alpine/webkit2gtk to a version that resolves this vulnerability.

    Fixed in 2.28.0-r0
  5. Upgrade

    Upgrade WebKitGTK and WPE WebKit to a version that resolves this vulnerability.

    Fixed in 2.28.0

Event History

Mar 2, 2020
CVE Published
via MITRE·10:11 PM
Data Sourced
via MITRE·10:11 PM
Description
Data Sourced
via NVD·11:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·11:15 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2020-10018?

CVE-2020-10018 is a memory corruption vulnerability in WebKitGTK and WPE WebKit versions before 2.28.0.

2

How severe is CVE-2020-10018?

CVE-2020-10018 has a severity rating of 9.8 out of 10, making it a critical vulnerability.

3

What is the impact of CVE-2020-10018?

CVE-2020-10018 may lead to arbitrary code execution.

4

How can I fix CVE-2020-10018?

CVE-2020-10018 has been fixed in version 2.28.0 of WebKitGTK and WPE WebKit with improved memory handling.

5

Where can I find more information about CVE-2020-10018?

More information about CVE-2020-10018 can be found at the following references: [CVE-2020-10018](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10018), [WebKit Changeset](https://trac.webkit.org/changeset/257292), [WebKitGTK Security Advisory](https://webkitgtk.org/security/WSA-2020-0003.html).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203