CVE-2020-10938: Integer Overflow

Published Mar 24, 2020
·
Updated

GraphicsMagick before 1.3.35 has an integer overflow and resultant heap-based buffer overflow in HuffmanDecodeImage in magick/compress.c.

Affected Software

21 affected componentsFixes available
debian/graphicsmagick
1.4+really1.3.36+hg16481-2+deb11u11.4+really1.3.40-41.4+really1.3.45+hg17689-1
GraphicsMagick Graphicsmagick<1.3.35
Debian Debian Linux=8.0
Debian Debian Linux=9.0
Debian Debian Linux=10.0
openSUSE Backports=sle-15-sp1
openSUSE Leap=15.1
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0
alpine/graphicsmagick<1.3.35-r0
1.3.35-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/graphicsmagick to a version that resolves this vulnerability.

    Fixed in 1.4+really1.3.36+hg16481-2+deb11u1Fixed in 1.4+really1.3.40-4Fixed in 1.4+really1.3.45+hg17689-1
  2. Upgrade

    Upgrade alpine/graphicsmagick to a version that resolves this vulnerability.

    Fixed in 1.3.35-r0

Event History

Mar 24, 2020
CVE Published
via MITRE·03:28 PM
Data Sourced
via MITRE·03:28 PM
Description
Data Sourced
via NVD·04:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·04:15 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2020-10938?

CVE-2020-10938 is a vulnerability in GraphicsMagick before version 1.3.35 that allows for an integer overflow and resultant heap-based buffer overflow in HuffmanDecodeImage.

2

How severe is CVE-2020-10938?

CVE-2020-10938 has a severity rating of 9.8 (Critical).

3

Which software versions are affected by CVE-2020-10938?

GraphicsMagick versions before 1.3.35 are affected by CVE-2020-10938.

4

How can I fix CVE-2020-10938?

To fix CVE-2020-10938, update your GraphicsMagick installation to version 1.3.35 or later.

5

Where can I find more information about CVE-2020-10938?

You can find more information about CVE-2020-10938 at the following references: [Reference 1](http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00049.html), [Reference 2](http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00051.html), [Reference 3](https://lists.debian.org/debian-lts-announce/2020/04/msg00007.html).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203