CVE-2020-10942: Input Validation
A stack buffer overflow issue was found in the getrawsocket() routine of the Host kernel accelerator for virtio net (vhost-net) driver. It could occur while doing an ictol(VHOSTNETSETBACKEND) call, and retrieving socket name in a kernel stack variable via getrawsocket(). A user able to perform ioctl(2) calls on the '/dev/vhost-net' device may use this flaw to crash the kernel resulting in DoS issue.
Other sources
In the Linux kernel before 5.5.8, getrawsocket in drivers/vhost/net.c lacks validation of an skfamily field, which might allow attackers to trigger kernel stack corruption via crafted system calls.
— Ubuntu
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:3.10.0-1160.rt56.1131.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-1160.el7 - Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:4.18.0-240.rt7.54.el8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-240.el8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.5.8 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Upgrade
Upgrade
Linux kernel (vhost-net)to a version that resolves this vulnerability.Fixed in 5.5.8
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2020-10942?
CVE-2020-10942 is classified as a high severity vulnerability due to the potential for a stack buffer overflow in the virtio net driver.
How do I fix CVE-2020-10942?
To fix CVE-2020-10942, users should upgrade to one of the patched versions of the kernel specified by Red Hat, such as 0:3.10.0-1160.rt56.1131.el7 or 0:4.18.0-240.el8.
What systems are affected by CVE-2020-10942?
CVE-2020-10942 affects various Linux distributions, including Red Hat, Ubuntu, and Debian, specifically older kernel versions.
Who is impacted by CVE-2020-10942?
Any user or organization utilizing affected kernel versions in their systems that employ the virtio net driver may be impacted by CVE-2020-10942.
What are the symptoms of CVE-2020-10942 exploitation?
Exploitation of CVE-2020-10942 may lead to system instability, crashes, or arbitrary code execution in severe cases.