CVE-2020-11041: Improper Validation of Array Index in FreeRDP
In FreeRDP less than or equal to 2.0.0, an outside controlled array index is used unchecked for data used as configuration for sound backend (alsa, oss, pulse, ...). The most likely outcome is a crash of the client instance followed by no or distorted sound or a session disconnect. If a user cannot upgrade to the patched version, a workaround is to disable sound for the session. This has been patched in 2.1.0.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
FreeRDPto a version that resolves this vulnerability.Fixed in 2.1.0 - Configuration
Disable sound for the session if upgrading to the patched version is not possible
FreeRDP sound = disabled
Event History
Frequently Asked Questions
What is CVE-2020-11041?
CVE-2020-11041 is a vulnerability in FreeRDP, version less than or equal to 2.0.0, where an outside controlled array index is used unchecked for data used as configuration for sound backend.
What is the severity of CVE-2020-11041?
The severity of CVE-2020-11041 is medium with a severity score of 2.7.
How can CVE-2020-11041 affect the system?
CVE-2020-11041 can result in a crash of the client instance, no or distorted sound, or a session disconnect.
Which software versions are affected by CVE-2020-11041?
FreeRDP versions up to and including 2.0.0, openSUSE Leap 15.1, and Debian Linux 10.0 are affected by CVE-2020-11041.
How can I fix CVE-2020-11041?
To fix CVE-2020-11041, update FreeRDP to a version higher than 2.0.0, or apply the necessary patches provided by the software vendor.