CVE-2020-11058: Improper Restriction of Operations within the Bounds of a Memory Buffer in FreeRDP
In FreeRDP after 1.1 and before 2.0.0, a stream out-of-bounds seek in rdpreadfontcapabilityset could lead to a later out-of-bounds read. As a result, a manipulated client or server might force a disconnect due to an invalid data read. This has been fixed in 2.0.0.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/freerdp2to a version that resolves this vulnerability.Fixed in 2.3.0+dfsg1-2+deb11u1Fixed in 2.3.0+dfsg1-2+deb11u3Fixed in 2.11.7+dfsg1-6~deb12u1 - Upgrade
Upgrade
FreeRDPto a version that resolves this vulnerability.Fixed in 2.0.0
Event History
Frequently Asked Questions
What is the severity of CVE-2020-11058?
The severity of CVE-2020-11058 is low.
Which versions of FreeRDP are affected by CVE-2020-11058?
FreeRDP versions after 1.1 and before 2.0.0 are affected by CVE-2020-11058.
How can a manipulated client or server exploit CVE-2020-11058?
A manipulated client or server might force a disconnect by exploiting the out-of-bounds read vulnerability in CVE-2020-11058.
Is there a fix for CVE-2020-11058?
Yes, CVE-2020-11058 has been fixed in version 2.0.0 of FreeRDP.
Where can I find more information about CVE-2020-11058?
You can find more information about CVE-2020-11058 at the following references: [CVE-2020-11058](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11058), [FreeRDP Security Advisory](https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-wjg2-2f82-466g), [Ubuntu Security Notice](https://ubuntu.com/security/notices/USN-4379-1).