CVE-2020-11565: Medium severity Linux Linux kernel vulnerability

Published Apr 1, 2020
·
Updated

DISPUTED An issue was discovered in the Linux kernel through 5.6.2. mpolparsestr in mm/mempolicy.c has a stack-based out-of-bounds write because an empty nodelist is mishandled during mount option parsing, aka CID-aa9f7d5172fa. NOTE: Someone in the security community disagrees that this is a vulnerability because the issue “is a bug in parsing mount options which can only be specified by a privileged user, so triggering the bug does not grant any powers not already held.”.

Other sources

An issue was discovered in the Linux kernel through 5.6.2. mpolparsestr in mm/mempolicy.c has a stack-based out-of-bounds write because an empty nodelist is mishandled during mount option parsing.

Reference and upstream commit: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=aa9f7d5172fac9bf1f09e678c35e287a40a7b7dd

— Red Hat

An out-of-bounds write flaw was found in the Linux kernel. An empty nodelist in mempolicy.c is mishandled durig mount option parsing leading to a stack-based out-of-bounds write. The highest threat from this vulnerability is to system availability.

Affected Software

11 affected componentsFixes available
redhat/kernel-rt<0:3.10.0-1160.rt56.1131.el7
0:3.10.0-1160.rt56.1131.el7
redhat/kernel-alt<0:4.14.0-115.26.1.el7a
0:4.14.0-115.26.1.el7a
redhat/kernel<0:3.10.0-1160.el7
0:3.10.0-1160.el7
redhat/kernel-rt<0:4.18.0-240.rt7.54.el8
0:4.18.0-240.rt7.54.el8
redhat/kernel<0:4.18.0-240.el8
0:4.18.0-240.el8
Linux Linux kernel<=5.6.2
Canonical Ubuntu Linux=14.04
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=20.04
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:3.10.0-1160.rt56.1131.el7
  2. Upgrade

    Upgrade redhat/kernel-alt to a version that resolves this vulnerability.

    Fixed in 0:4.14.0-115.26.1.el7a
  3. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:3.10.0-1160.el7
  4. Upgrade

    Upgrade redhat/kernel-rt to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-240.rt7.54.el8
  5. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 0:4.18.0-240.el8
  6. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
  7. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Patch aa9f7d5172fac9bf1f09e678c35e287a40a7b7dd

Event History

Apr 1, 2020
CVE Published
12:00 AM
Apr 6, 2020
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·12:08 AM
Data Sourced
via MITRE·12:08 AM
Description
Disputed
01:15 AM
Data Sourced
via NVD·01:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Apr 16, 2020
Data Sourced
via Red Hat·04:40 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2020-11565?

CVE-2020-11565 has been reported as a disputed vulnerability with a potential for stack-based out-of-bounds writes.

2

How do I fix CVE-2020-11565?

To fix CVE-2020-11565, update your kernel to one that has removed the vulnerability, such as kernel version 5.10.223-1 or later.

3

Which Linux distributions are affected by CVE-2020-11565?

CVE-2020-11565 affects multiple Linux distributions, including several versions of Ubuntu and Red Hat.

4

What versions of the kernel are vulnerable to CVE-2020-11565?

The vulnerability CVE-2020-11565 affects Linux kernel versions up to and including 5.6.2.

5

Is CVE-2020-11565 exploitable?

Exploitation of CVE-2020-11565 may lead to arbitrary code execution due to stack corruption, although the exact risk may vary based on configurations.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203