CVE-2020-11608: Null Pointer Dereference

Published Apr 7, 2020
·
Updated

An issue was discovered in the Linux kernel before 5.6.1. drivers/media/usb/gspca/ov519.c allows NULL pointer dereferences in ov511modeinitregs and ov518modeinitregs when there are zero endpoints, aka CID-998912346c0d.

Other sources

An issue was discovered in the Linux kernel before 5.6.1. drivers/media/usb/gspca/ov519.c allows NULL pointer dereferences in ov511modeinitregs and ov518modeinitregs when there are zero endpoints.

Reference and upstream commit: https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.6.1 https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=998912346c0da53a6dbb71fab3a138586b596b30

— Red Hat

Affected Software

4 affected componentsFixes available
Linux Linux kernel<5.6.1
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=18.04
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Apr 7, 2020
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·01:55 PM
Data Sourced
via MITRE·01:55 PM
Description
Data Sourced
via NVD·02:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
May 8, 2020
Data Sourced
via Red Hat·04:55 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2020-11608?

CVE-2020-11608 has a medium severity due to its potential to cause NULL pointer dereferences affecting system stability.

2

How do I fix CVE-2020-11608?

To fix CVE-2020-11608, upgrade the Linux kernel to version 5.6.1 or later.

3

Which versions of Linux are affected by CVE-2020-11608?

CVE-2020-11608 affects Linux kernel versions prior to 5.6.1 and specific versions of Ubuntu 16.04 and 18.04.

4

What components are involved in CVE-2020-11608?

CVE-2020-11608 specifically involves the ov511_mode_init_regs and ov518_mode_init_regs functions in the gspca driver.

5

Is CVE-2020-11608 a remote exploit?

CVE-2020-11608 is not considered a remote exploit as it affects local drivers and requires direct access.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203