CVE-2020-13310: Medium severity GitLab GitLab vulnerability
A vulnerability was discovered in GitLab runner versions before 13.1.3, 13.2.3 and 13.3.1. It was possible to make the gitlab-runner process crash by sending malformed queries, resulting in a denial of service.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
gitlab-runnerto a version that resolves this vulnerability.Fixed in 13.1.3 - Upgrade
Upgrade
gitlab-runnerto a version that resolves this vulnerability.Fixed in 13.2.3 - Upgrade
Upgrade
gitlab-runnerto a version that resolves this vulnerability.Fixed in 13.3.1
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13310?
CVE-2020-13310 is classified as a denial of service vulnerability.
How do I fix CVE-2020-13310?
To fix CVE-2020-13310, you should upgrade to GitLab runner version 13.1.3, 13.2.3, or 13.3.1 or later.
Which versions of GitLab Runner are affected by CVE-2020-13310?
CVE-2020-13310 affects GitLab runner versions prior to 13.1.3, 13.2.3, and 13.3.1.
What type of attack can exploit CVE-2020-13310?
CVE-2020-13310 can be exploited through denial of service attacks by sending malformed queries.
What is the impact of the CVE-2020-13310 vulnerability?
The impact of CVE-2020-13310 includes crashing the gitlab-runner process, leading to service disruption.