CVE-2020-13312: Critical severity GitLab GitLab vulnerability
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. GitLab OAuth endpoint was vulnerable to brute-force attacks through a specific parameter.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.8 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13312?
CVE-2020-13312 has a medium severity rating due to its potential for brute-force attacks on the GitLab OAuth endpoint.
How do I fix CVE-2020-13312?
To fix CVE-2020-13312, upgrade GitLab to versions 13.1.10, 13.2.8, or 13.3.4 or later.
What versions of GitLab are affected by CVE-2020-13312?
CVE-2020-13312 affects GitLab versions before 13.1.10, 13.2.8, and 13.3.4.
Can CVE-2020-13312 be exploited remotely?
Yes, CVE-2020-13312 can be exploited remotely if an attacker targets the OAuth endpoint.
What type of attack does CVE-2020-13312 enable?
CVE-2020-13312 enables brute-force attacks against the GitLab OAuth endpoint.