CVE-2020-13316: Medium severity GitLab GitLab vulnerability
A vulnerability was discovered in GitLab versions before 13.1.10, 13.2.8 and 13.3.4. GitLab was not validating a Deploy-Token and allowed a disabled repository be accessible via a git command line.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.1.10 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.2.8 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13316?
CVE-2020-13316 has a medium severity rating due to its potential to allow unauthorized access to disabled repositories.
How do I fix CVE-2020-13316?
To fix CVE-2020-13316, upgrade your GitLab installation to version 13.1.10, 13.2.8, or 13.3.4 or later.
Which versions of GitLab are affected by CVE-2020-13316?
CVE-2020-13316 affects GitLab versions prior to 13.1.10, 13.2.8, and 13.3.4.
What kind of vulnerability is CVE-2020-13316?
CVE-2020-13316 is a security vulnerability related to improper validation of Deploy-Tokens.
Can I still access my repositories if I have CVE-2020-13316?
Yes, if you are using an affected version, your disabled repositories may still be accessible via the git command line.