CVE-2020-13672: Drupal core - Critical - Cross-site scripting - SA-CORE-2021-002
Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circumstances. This issue affects: Drupal Core 9.1.x versions prior to 9.1.7; 9.0.x versions prior to 9.0.12; 8.9.x versions prior to 8.9.14; 7.x versions prior to 7.80.
Other sources
Drupal core - Critical - Cross-site scripting - SA-CORE-2021-002
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/drupal/drupalto a version that resolves this vulnerability.Fixed in 9.1.7 - Upgrade
Upgrade
composer/drupal/drupalto a version that resolves this vulnerability.Fixed in 9.0.12 - Upgrade
Upgrade
composer/drupal/drupalto a version that resolves this vulnerability.Fixed in 8.9.14 - Upgrade
Upgrade
composer/drupal/drupalto a version that resolves this vulnerability.Fixed in 7.80 - Upgrade
Upgrade
composer/drupal/coreto a version that resolves this vulnerability.Fixed in 9.1.7 - Upgrade
Upgrade
composer/drupal/coreto a version that resolves this vulnerability.Fixed in 9.0.12 - Upgrade
Upgrade
composer/drupal/coreto a version that resolves this vulnerability.Fixed in 8.9.14 - Upgrade
Upgrade
composer/drupal/coreto a version that resolves this vulnerability.Fixed in 7.80 - Upgrade
Upgrade
Drupal coreto a version that resolves this vulnerability.Fixed in 9.1.7 - Upgrade
Upgrade
Drupal coreto a version that resolves this vulnerability.Fixed in 9.0.12 - Upgrade
Upgrade
Drupal coreto a version that resolves this vulnerability.Fixed in 8.9.14 - Upgrade
Upgrade
Drupal coreto a version that resolves this vulnerability.Fixed in 7.80
Event History
Frequently Asked Questions
What is the severity of CVE-2020-13672?
It is classified as a critical vulnerability.
What is the description of CVE-2020-13672?
CVE-2020-13672 is a critical cross-site scripting vulnerability in Drupal core.
Which versions of Drupal core are affected by CVE-2020-13672?
Drupal core versions 7.0.0 to 7.80, and 8.0.0 to 8.9.14 are affected by CVE-2020-13672.
What is the reference for CVE-2020-13672?
The reference for CVE-2020-13672 is https://www.drupal.org/sa-core-2021-002.
How do I fix CVE-2020-13672?
To fix CVE-2020-13672, update your Drupal core to version 7.81 or 8.9.15.