CVE-2020-13677: Drupal core access bypass vulnerability

Published Feb 11, 2022
·
Updated

Drupal core access bypass vulnerability

Other sources

Under some circumstances, the Drupal core JSON:API module does not properly restrict access to certain content, which may result in unintended access bypass. Sites that do not have the JSON:API module enabled are not affected.

Affected Software

9 affected componentsFixes available
composer/drupal/core>=9.2.0<9.2.6
9.2.6
composer/drupal/core>=9.1.0<9.1.13
9.1.13
composer/drupal/core>=8.0.0<8.9.19
8.9.19
Drupal Drupal>=8.0.0<8.9.19
Drupal Drupal>=9.1.0<9.1.13
Drupal Drupal>=9.2.0<9.2.6
composer/drupal/core>=9.2.0, <9.2.6
9.2.6
composer/drupal/core>=9.1.0, <9.1.13
9.1.13
composer/drupal/core>=8.0.0, <8.9.19
8.9.19

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 9.2.6
  2. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 9.1.13
  3. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 8.9.19

Event History

Feb 11, 2022
CVE Published
via MITRE·03:55 PM
Data Sourced
via MITRE·03:55 PM
DescriptionWeakness
Data Sourced
via NVD·04:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Feb 12, 2022
Advisory Published
12:00 AM
Data Sourced
via GitHub·12:00 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·12:00 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2020-13677?

CVE-2020-13677 is a vulnerability in the Drupal core JSON:API module that can result in unintended access bypass.

2

Which sites are affected by CVE-2020-13677?

Sites that have the Drupal core JSON:API module enabled and are running versions between 8.0.0 and 8.9.19, 9.1.0 and 9.1.13, or 9.2.0 and 9.2.6 are affected.

3

What is the severity of CVE-2020-13677?

CVE-2020-13677 has a severity rating of 7.5, which is considered high.

4

How can I fix CVE-2020-13677?

To fix CVE-2020-13677, Drupal site owners should update the JSON:API module to version 8.9.19, 9.1.13, or 9.2.6, depending on the version being used.

5

Where can I find more information about CVE-2020-13677?

You can find more information about CVE-2020-13677 on the National Vulnerability Database (NVD), Drupal's security advisory, and the GitHub commit.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203