CVE-2020-13754: Buffer Overflow

Published Jun 1, 2020
·
Updated

An OOB access issue was found in the Message Signalled Interrupt (MSI-X) device support of QEMU. It could occur while performing MSI-X mmio operations when a guest sent address goes beyond the mmio region. A guest user/process may use this flaw to crash the QEMU process resulting in DoS scenario.

Upstream patch: --------------- -> https://lists.gnu.org/archive/html/qemu-devel/2020-06/msg03732.html

Reference: ---------- -> https://www.openwall.com/lists/oss-security/2020/06/01/6

Other sources

hw/pci/msix.c in QEMU 4.2.0 allows guest OS users to trigger an out-of-bounds access via a crafted address in an msi-x mmio operation.

— Launchpad

Affected Software

17 affected componentsFixes available
redhat/qemu<5.0.1
5.0.1
Qemu Qemu<=5.0.1
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=20.04
Debian Debian Linux=9.0
Debian Debian Linux=10.0
debian/qemu
1:7.2+dfsg-7+deb12u181:7.2+dfsg-7+deb12u151:10.0.13+ds-0+deb13u11:10.0.2+ds-2+deb13u11:11.1.2+ds-31:11.1.3+ds-1
alpine/qemu<5.0.0-r0
5.0.0-r0
alpine/qemu<5.0.0-r0
5.0.0-r0
alpine/qemu<5.0.0-r0
5.0.0-r0
alpine/qemu<5.0.0-r0
5.0.0-r0
alpine/qemu<5.0.0-r0
5.0.0-r0
alpine/qemu<5.0.0-r0
5.0.0-r0
alpine/qemu<5.0.0-r0
5.0.0-r0
alpine/qemu<5.0.0-r0
5.0.0-r0
alpine/qemu<5.0.0-r0
5.0.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/QEMU to a version that resolves this vulnerability.

    Fixed in 5.0.1
  2. Upgrade

    Upgrade debian/qemu to a version that resolves this vulnerability.

    Fixed in 1:5.2+dfsg-11+deb11u3Fixed in 1:5.2+dfsg-11+deb11u4Fixed in 1:7.2+dfsg-7+deb12u13Fixed in 1:10.0.0+ds-2

Event History

Jun 2, 2020
CVE Published
via MITRE·01:37 PM
Data Sourced
via MITRE·01:37 PM
Description
Data Sourced
via NVD·02:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2020-13754?

CVE-2020-13754 is a vulnerability in QEMU 4.2.0 that allows guest OS users to trigger an out-of-bounds access via a crafted address in an msi-x mmio operation.

2

How do I know if I am affected by CVE-2020-13754?

You are affected by CVE-2020-13754 if you are using QEMU 4.2.0.

3

What is the severity of CVE-2020-13754?

The severity of CVE-2020-13754 is medium (6.7).

4

How do I fix CVE-2020-13754 in Red Hat?

To fix CVE-2020-13754 in Red Hat, you need to update QEMU to version 5.0.1.

5

How do I fix CVE-2020-13754 in Ubuntu?

To fix CVE-2020-13754 in Ubuntu, you need to update QEMU to the specified versions: 1:2.5+dfsg-5ubuntu10.45 for Xenial, 1:2.11+dfsg-1ubuntu7.31 for Bionic, and 1:4.2-3ubuntu6.4 for Focal.

6

How do I fix CVE-2020-13754 in Debian?

To fix CVE-2020-13754 in Debian, you need to update QEMU to the specified versions: 1:3.1+dfsg-8+deb10u8, 1:3.1+dfsg-8+deb10u11, 1:5.2+dfsg-11+deb11u3, 1:5.2+dfsg-11+deb11u2, 1:7.2+dfsg-7+deb12u2, or 1:8.1.2+ds-1.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203