CVE-2020-14573: Low severity Oracle JDK vulnerability
A flaw was found in the Grall compiler in the Hotspot component of OpenJDK. Incomplete checks of referenced data types could cause interface calls to accept incompatible types.
Other sources
Vulnerability in the Java SE product of Oracle Java SE (component: Hotspot). Supported versions that are affected are Java SE: 11.0.7 and 14.0.1. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE accessible data. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. CVSS 3.1 Base Score 3.7 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N).
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/javato a version that resolves this vulnerability.Fixed in 11-openjdk-1:11.0.8.10-0.el7_8 - Upgrade
Upgrade
redhat/javato a version that resolves this vulnerability.Fixed in 11-openjdk-1:11.0.8.10-0.el8_2 - Upgrade
Upgrade
redhat/javato a version that resolves this vulnerability.Fixed in 11-openjdk-1:11.0.8.10-0.el8_0 - Upgrade
Upgrade
redhat/javato a version that resolves this vulnerability.Fixed in 11-openjdk-1:11.0.8.10-0.el8_1 - Upgrade
Upgrade
debian/openjdk-11to a version that resolves this vulnerability.Fixed in 11.0.24+8-2~deb11u1Fixed in 11.0.30+7-1~deb11u1Fixed in 11.0.30+7-1 - Upgrade
Upgrade
alpine/openjdk11to a version that resolves this vulnerability.Fixed in 11.0.8_p10-r0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is CVE-2020-14573?
CVE-2020-14573 is a vulnerability in the Java SE product of Oracle Java SE that allows an unauthenticated attacker with network access to compromise Java SE.
Which versions of Java SE are affected by CVE-2020-14573?
Java SE versions 11.0.7 and 14.0.1 are affected by CVE-2020-14573.
How severe is CVE-2020-14573?
CVE-2020-14573 has a severity rating of medium, with a CVSS score of 3.7.
How can an attacker exploit CVE-2020-14573?
An attacker can exploit CVE-2020-14573 by leveraging multiple protocols to compromise Java SE.
Where can I find more information about CVE-2020-14573?
You can find more information about CVE-2020-14573 on the Oracle Security Alerts website and the Red Hat Errata website.