CVE-2020-14860: Low severity Oracle MySQL vulnerability

Published Oct 21, 2020
·
Updated

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Security: Roles). Supported versions that are affected are 8.0.21 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data.

External References:

https://www.oracle.com/security-alerts/cpuoct2020.html#AppendixMSQL

Other sources

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Security: Roles). Supported versions that are affected are 8.0.21 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data. CVSS 3.1 Base Score 2.7 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N).

— MITRE

Affected Software

7 affected componentsFixes available
redhat/mysql<8.0.22
8.0.22
Oracle MySQL>=8.0.0<=8.0.21
NetApp Active Iq Unified Manager Vmware Vsphere
NetApp Active Iq Unified Manager Windows
NetApp OnCommand Insight
NetApp OnCommand Workflow Automation
NetApp Snapcenter

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/mysql to a version that resolves this vulnerability.

    Fixed in 8.0.22

Event History

Oct 21, 2020
CVE Published
via MITRE·02:04 PM
Data Sourced
via MITRE·02:04 PM
DescriptionSeverityWeakness
Event
via MITRE·02:04 PM

Frequently Asked Questions

1

What is the severity of CVE-2020-14860?

CVE-2020-14860 is classified as an easily exploitable vulnerability that poses a high risk due to its implications for MySQL Server security.

2

How do I fix CVE-2020-14860?

To fix CVE-2020-14860, upgrade your MySQL Server to version 8.0.22 or later.

3

What versions of MySQL are affected by CVE-2020-14860?

CVE-2020-14860 affects MySQL versions 8.0.21 and prior.

4

Can an attacker exploit CVE-2020-14860 remotely?

Yes, CVE-2020-14860 allows a high privileged attacker with network access to compromise MySQL Server.

5

What components of MySQL are impacted by CVE-2020-14860?

CVE-2020-14860 specifically impacts the Server security roles component within MySQL.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203