CVE-2020-15306: Buffer Overflow

Published Jun 26, 2020
·
Updated

An issue was discovered in OpenEXR before v2.5.2. Invalid chunkCount attributes could cause a heap buffer overflow in getChunkOffsetTableSize() in IlmImf/ImfMisc.cpp.

Affected Software

25 affected componentsFixes available
OpenEXR OpenEXR<2.5.2
Fedoraproject Fedora=31
Fedoraproject Fedora=32
openSUSE Leap=15.1
openSUSE Leap=15.2
Debian Debian Linux=9.0
Debian Debian Linux=10.0
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=19.10
Canonical Ubuntu Linux=20.04
debian/openexr
3.1.5-53.1.13-23.4.16+ds-1
alpine/openexr<2.4.1-r3
2.4.1-r3
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0
alpine/openexr<2.5.2-r0
2.5.2-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/openexr to a version that resolves this vulnerability.

    Fixed in 3.1.5-5Fixed in 3.1.13-2Fixed in 3.4.16+ds-1

Event History

Jun 26, 2020
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·12:38 AM
Data Sourced
via MITRE·12:38 AM
Description
Data Sourced
via NVD·01:15 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2020-15306?

CVE-2020-15306 is a vulnerability discovered in OpenEXR before v2.5.2 that could cause a heap buffer overflow.

2

What is the severity of CVE-2020-15306?

The severity of CVE-2020-15306 is medium with a severity value of 5.5.

3

Which software versions are affected by CVE-2020-15306?

OpenEXR versions up to and excluding v2.5.2 are affected by CVE-2020-15306.

4

How can I fix CVE-2020-15306?

To fix CVE-2020-15306, update your OpenEXR installation to version 2.5.2 or higher.

5

Where can I find more information about CVE-2020-15306?

You can find more information about CVE-2020-15306 at the following links: [CVE-2020-15306](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-15306), [OpenEXR Changelog](https://github.com/AcademySoftwareFoundation/openexr/blob/master/CHANGES.md), [OpenEXR Security Advisory](https://github.com/AcademySoftwareFoundation/openexr/blob/master/SECURITY.md).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203