CVE-2020-16119: DCCP CCID structure use-after-free
Last updated 12 October 2026
Other sources
Use-after-free vulnerability in the Linux kernel exploitable by a local attacker due to reuse of a DCCP socket with an attached dccpshctxccid object as a listener after being released. Fixed in Ubuntu Linux kernel 5.4.0-51.56, 5.3.0-68.63, 4.15.0-121.123, 4.4.0-193.224, 3.13.0.182.191 and 3.2.0-149.196.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1 - Upgrade
Upgrade
Ubuntu Linux kernelto a version that resolves this vulnerability.Fixed in 5.4.0-51.56 - Upgrade
Upgrade
Ubuntu Linux kernelto a version that resolves this vulnerability.Fixed in 5.3.0-68.63 - Upgrade
Upgrade
Ubuntu Linux kernelto a version that resolves this vulnerability.Fixed in 4.15.0-121.123 - Upgrade
Upgrade
Ubuntu Linux kernelto a version that resolves this vulnerability.Fixed in 4.4.0-193.224 - Upgrade
Upgrade
Ubuntu Linux kernelto a version that resolves this vulnerability.Fixed in 3.13.0.182.191 - Upgrade
Upgrade
Ubuntu Linux kernelto a version that resolves this vulnerability.Fixed in 3.2.0-149.196 - Configuration
Add the following lines to /etc/modprobe.d/blacklist-dccp.conf: alias net-pf-10-proto-0-type-6 off; alias net-pf-10-proto-33-type-6 off; alias net-pf-2-proto-0-type-6 off; alias net-pf-2-proto-33-type-6 off.
Linux kernel DCCP module autoloading DCCP protocol autoloading aliases = off
Event History
Frequently Asked Questions
What is the severity of CVE-2020-16119?
CVE-2020-16119 is considered a high-severity vulnerability that can be exploited by local attackers.
How do I fix CVE-2020-16119?
To fix CVE-2020-16119, upgrade to a fixed version of the Linux kernel, such as 5.4.0-51.56 or newer.
Which systems are affected by CVE-2020-16119?
CVE-2020-16119 affects various Linux distributions, including specific versions of Ubuntu and Debian.
Can CVE-2020-16119 be exploited remotely?
No, CVE-2020-16119 requires local access to be exploited.
What type of vulnerability is CVE-2020-16119?
CVE-2020-16119 is a use-after-free vulnerability within the Linux kernel.