CVE-2020-21603: Buffer Overflow
Last updated 24 July 2024
Other sources
libde265 v1.0.4 contains a heap buffer overflow in the putqpel00fallback16 function, which can be exploited via a crafted a file.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/libde265to a version that resolves this vulnerability.Fixed in 1.0.11-1+deb12u2Fixed in 1.0.11-1+deb12u3Fixed in 1.0.15-1+deb13u2Fixed in 1.1.3-1
Event History
Frequently Asked Questions
What is the severity of CVE-2020-21603?
CVE-2020-21603 is considered a critical vulnerability due to the presence of a heap buffer overflow that can lead to remote code execution.
How do I fix CVE-2020-21603?
To mitigate CVE-2020-21603, update the libde265 package to versions 1.0.11-0+deb11u3, 1.0.11-0+deb11u1, 1.0.11-1+deb12u2, or 1.0.15-1.
Which versions of libde265 are affected by CVE-2020-21603?
CVE-2020-21603 affects libde265 version 1.0.4 and earlier versions.
What is the nature of the vulnerability in CVE-2020-21603?
CVE-2020-21603 is characterized by a heap buffer overflow in the put_qpel_0_0_fallback_16 function.
Can I exploit CVE-2020-21603 through file manipulation?
Yes, CVE-2020-21603 can be exploited via a crafted file that triggers the underlying vulnerability.