CVE-2020-24599: XSS
Published Aug 26, 2020
·Updated
An issue was discovered in Joomla! before 3.9.21. Lack of escaping in modlatestactions allows XSS attacks.
Affected Software
1 affected component
Joomla Joomla\!>=3.9.0<3.9.21
Event History
Aug 26, 2020
CVE Published
via MITRE·09:25 PM
Data Sourced
via MITRE·09:25 PM
Description
Frequently Asked Questions
1
What is the severity of CVE-2020-24599?
CVE-2020-24599 has a medium severity level due to its potential for enabling cross-site scripting (XSS) attacks.
2
How do I fix CVE-2020-24599?
To fix CVE-2020-24599, upgrade to Joomla! version 3.9.21 or later to ensure proper escaping in mod_latestactions.
3
What type of attacks can CVE-2020-24599 facilitate?
CVE-2020-24599 can facilitate cross-site scripting (XSS) attacks that may allow attackers to execute malicious scripts in the context of a user's session.
4
What are the affected Joomla! versions for CVE-2020-24599?
CVE-2020-24599 affects Joomla! versions prior to 3.9.21, specifically from version 3.9.0 up to 3.9.20.
5
Who is impacted by CVE-2020-24599?
Any Joomla! users running versions prior to 3.9.21 are at risk of being impacted by CVE-2020-24599.