CVE-2020-24606: High severity IBM Security Guardium vulnerability

Published Aug 24, 2020
·
Updated

Last updated 25 August 2025

Other sources

Squid before 4.13 and 5.x before 5.0.4 allows a trusted peer to perform Denial of Service by consuming all available CPU cycles during handling of a crafted Cache Digest response message. This only occurs when cachepeer is used with the cache digests feature. The problem exists because peerDigestHandleReply() livelocking in peerdigest.cc mishandles EOF.

— Launchpad

Squid is vulnerable to a denial of service, caused by the mishandling of EOF in the peerDigestHandleReply function in peerdigest.cc. By sending a specially-crafted Cache Digest response message, a remote attacker could exploit this vulnerability to consume all available CPU cycles.

— IBM

Affected Software

20 affected componentsFixes available
debian/squid<=4.6-1, <=4.12-1, <=4.6-1+deb10u3
4.13-14.6-1+deb10u4
IBM Security Guardium<=10.5
IBM Security Guardium<=10.6
IBM Security Guardium<=11.0
IBM Security Guardium<=11.1
IBM Security Guardium<=11.2
IBM Security Guardium<=11.3
Squid-Cache Squid>=3.0<4.13
Squid-Cache Squid>=5.0.1<5.0.4
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=20.04
Debian Debian Linux=9.0
Debian Debian Linux=10.0
Fedoraproject Fedora=31
Fedoraproject Fedora=32
Fedoraproject Fedora=33
openSUSE Leap=15.1
openSUSE Leap=15.2
debian/squid
4.13-10+deb11u34.13-10+deb11u65.7-2+deb12u55.7-2+deb12u46.13-2+deb13u17.5-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/squid to a version that resolves this vulnerability.

    Fixed in 4.13-1Fixed in 4.6-1+deb10u4
  2. Upgrade

    Upgrade debian/squid to a version that resolves this vulnerability.

    Fixed in 4.13-10+deb11u3Fixed in 4.13-10+deb11u6Fixed in 5.7-2+deb12u5Fixed in 5.7-2+deb12u4Fixed in 6.13-2+deb13u1Fixed in 7.5-1
  3. Upgrade

    Upgrade Squid to a version that resolves this vulnerability.

    Fixed in 4.13
  4. Upgrade

    Upgrade Squid to a version that resolves this vulnerability.

    Fixed in 5.0.4

Event History

Aug 24, 2020
CVE Published
via MITRE·05:06 PM
Data Sourced
via MITRE·05:06 PM
DescriptionSeverity
Data Sourced
via NVD·06:15 PM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2020-24606?

CVE-2020-24606 is a vulnerability in Squid, a cache proxy server, that allows a trusted peer to perform a Denial of Service attack by consuming all available CPU cycles.

2

Which versions of Squid are affected by CVE-2020-24606?

Squid versions before 4.13 and 5.x before 5.0.4 are affected by CVE-2020-24606.

3

How severe is CVE-2020-24606?

CVE-2020-24606 has a severity rating of 8.6 (high).

4

What is the recommended fix for CVE-2020-24606?

To fix CVE-2020-24606, it is recommended to update Squid to version 4.13 or 5.0.4 or later.

5

Where can I find more information about CVE-2020-24606?

More information about CVE-2020-24606 can be found on the official Squid website and the OpenSUSE security announcements.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203