CVE-2020-25717: Input Validation

Published Nov 3, 2021
·
Updated

A flaw was found in the way Samba maps domain users to local users. An authenticated attacker could use this flaw to cause possible privilege escalation.

Other sources

As per upstream advisory:

Windows Active Directory domains have, but default, a feature to allow users to create computer accounts, controlled by ms-DS-MachineAccountQuota.

Likewise, some (presumably trusted) users have the right to create new users or computers in Active Directory Domains, both Samba and Windows based.

When Samba, as an AD Domain member accepts a Kerberos ticket, it must map the information found therein to a local user. This is done via the name in the Kerberos PAC, or the name in the ticket (if there is no PAC).

Samba will attempt to find a user "DOMAIN\user" before falling back to just "user".

If the DOMAIN\user lookup can be made to fail, then a privilege escallation is possible.

— Red Hat

Affected Software

55 affected componentsFixes available
redhat/samba<0:4.10.16-17.el7_9
0:4.10.16-17.el7_9
redhat/samba<0:4.14.5-7.el8_5
0:4.14.5-7.el8_5
redhat/samba<0:4.11.2-18.el8_2
0:4.11.2-18.el8_2
redhat/samba<0:4.13.3-8.el8_4
0:4.13.3-8.el8_4
redhat/samba<0:4.11.6-114.el7
0:4.11.6-114.el7
redhat/samba<0:4.14.5-204.el8
0:4.14.5-204.el8
redhat/redhat-virtualization-host<0:4.3.21-20220126.0.el7_9
0:4.3.21-20220126.0.el7_9
redhat/samba<4.15.2
4.15.2
redhat/samba<4.14.10
4.14.10
redhat/samba<4.13.14
4.13.14
debian/samba
2:4.13.13+dfsg-1~deb11u62:4.17.12+dfsg-0+deb12u12:4.21.1+dfsg-2
Samba Samba>=3.0.0<4.13.14
Samba Samba>=4.14.0<4.14.10
Samba Samba>=4.15.0<4.15.2
Debian Debian Linux=9.0
Debian Debian Linux=10.0
Fedoraproject Fedora=33
Fedoraproject Fedora=34
Fedoraproject Fedora=35
redhat Codeready Linux Builder
redhat Gluster Storage=3.0
redhat Gluster Storage=3.5
redhat Openstack=13
redhat Openstack=16.1
redhat Openstack=16.2
redhat Virtualization=4.0
redhat Virtualization Host=4.0
redhat Enterprise Linux=7.0
redhat Enterprise Linux=8.0
redhat Enterprise Linux Desktop=7.0
redhat Enterprise Linux Eus=8.2
redhat Enterprise Linux Eus=8.4
redhat Enterprise Linux For Ibm Z Systems=7.0
redhat Enterprise Linux For Ibm Z Systems=8.0
redhat Enterprise Linux For Ibm Z Systems Eus=8.2
redhat Enterprise Linux For Ibm Z Systems Eus=8.4
redhat Enterprise Linux For Power Big Endian=7.0
redhat Enterprise Linux For Power Little Endian=7.0
redhat Enterprise Linux For Power Little Endian=8.0
redhat Enterprise Linux For Power Little Endian Eus=8.2
redhat Enterprise Linux For Power Little Endian Eus=8.4
redhat Enterprise Linux For Scientific Computing=7.0
redhat Enterprise Linux Resilient Storage=7.0
redhat Enterprise Linux Server=7.0
redhat Enterprise Linux Server Aus=8.2
redhat Enterprise Linux Server Aus=8.4
redhat Enterprise Linux Server Tus=8.4
redhat Enterprise Linux Server Update Services For Sap Solutions=8.2
redhat Enterprise Linux Server Update Services For Sap Solutions=8.4
redhat Enterprise Linux Tus=8.2
redhat Enterprise Linux Workstation=7.0
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=20.04
Canonical Ubuntu Linux=21.04
Canonical Ubuntu Linux=21.10

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/samba to a version that resolves this vulnerability.

    Fixed in 0:4.10.16-17.el7_9
  2. Upgrade

    Upgrade redhat/samba to a version that resolves this vulnerability.

    Fixed in 0:4.14.5-7.el8_5
  3. Upgrade

    Upgrade redhat/samba to a version that resolves this vulnerability.

    Fixed in 0:4.11.2-18.el8_2
  4. Upgrade

    Upgrade redhat/samba to a version that resolves this vulnerability.

    Fixed in 0:4.13.3-8.el8_4
  5. Upgrade

    Upgrade redhat/samba to a version that resolves this vulnerability.

    Fixed in 0:4.11.6-114.el7
  6. Upgrade

    Upgrade redhat/samba to a version that resolves this vulnerability.

    Fixed in 0:4.14.5-204.el8
  7. Upgrade

    Upgrade redhat/redhat-virtualization-host to a version that resolves this vulnerability.

    Fixed in 0:4.3.21-20220126.0.el7_9
  8. Upgrade

    Upgrade redhat/samba to a version that resolves this vulnerability.

    Fixed in 4.15.2
  9. Upgrade

    Upgrade redhat/samba to a version that resolves this vulnerability.

    Fixed in 4.14.10
  10. Upgrade

    Upgrade redhat/samba to a version that resolves this vulnerability.

    Fixed in 4.13.14
  11. Upgrade

    Upgrade debian/samba to a version that resolves this vulnerability.

    Fixed in 2:4.13.13+dfsg-1~deb11u6Fixed in 2:4.17.12+dfsg-0+deb12u1Fixed in 2:4.21.1+dfsg-2
  12. Configuration

    Set gensec:require_pac=true in smb.conf; this relies on nss_winbind being in use, winbind use default domain = no, and no error paths being hit.

    Samba gensec:require_pac = true
  13. Compensating control

    Pre-create disabled users in Active Directory matching all privileged local usernames that are not held in Active Directory, including names such as root or other privileged names used by AD-connected services, so DOMAIN\user lookups do not fall back to the local username.

Event History

Nov 9, 2021
CVE Published
12:00 AM
Event
12:00 AM
Feb 18, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness

Frequently Asked Questions

1

What is the severity of CVE-2020-25717?

CVE-2020-25717 is classified as a medium severity vulnerability as it allows for potential privilege escalation for authenticated attackers.

2

How do I fix CVE-2020-25717?

To remediate CVE-2020-25717, you should update Samba to a patched version as specified in your vendor's advisory.

3

What systems are affected by CVE-2020-25717?

CVE-2020-25717 affects various versions of Samba on Red Hat and Debian systems, including specific versions noted in the vulnerability advisory.

4

Is CVE-2020-25717 exploitable remotely?

No, CVE-2020-25717 requires authenticated access to exploit, meaning an attacker must already have valid credentials.

5

What versions of Samba should I upgrade to mitigate CVE-2020-25717?

To mitigate CVE-2020-25717, upgrade Samba to versions 4.10.16-17.el7_9, 4.14.5-7.el8_5, or later secure versions as indicated by your distribution.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203